plane icon Welcome to Microsoft Flight Simulator’s SDK Q&A Platform!

You have questions regarding the SDK? DevMode Tools? SimConnect? You would like to submit an idea for future improvements, seek help or exchange knowledge? You’re in the right place.


Please take a moment to read the platform’s guidelines before you get started!


question

NAVData avatar image
NAVData asked MiGMan_Flight_Sim_Museum commented

SU10 beta (1.27.21.0) - PLN file with custom waypoints

Hi,

we have received a report (the same as in the MSFS beta forum https://forums.flightsimulator.com/t/navigation-loading-custom-waypoints-from-pln-files-is-broken-on-some-systems/543444?u=navdata) according a strange issue with loaded PLN-files which includes custom waypoints, in combination with our Navigraph Navdata package.


Preparing the test case (in SU10 beta or the current version, no difference):

1. Navigraph Navdata Package installed

2. Create a flightplan on the WorldMap from A - B

3. Add a custom waypoint(s) and save the flightplan as per default FLT file (which creates automatically a PLN file too)

startingposition-v127210.png



Test scenario #1: SU10 beta - load the FLT file

Result: custom waypoints in place and correct

load-flt-file-v127210.png


Test scenario #2: SU10 beta - load the PLN file

Result: the custom waypoints are somewhere but not on the correct place

load-pln-file-v127210.png


Test scenario #3: current sim version 1.26.5.0 - load the PLN file

Result: custom waypoints in place and correct

load-pln-file-v12650.png


So, something is changed between the current sim version and the latest SU10 beta. I have used the same PLN file in all test cases, and also the same Navigraph Navdata files but the result is differ between the current version and the SU10 beta.


Question:

  • Why is the flightplan correct when I load the FLT file and why is it not correct when I load the PLN file?
  • Why is the flightplan correct in the current sim version when I load the PLN file, and why not when I load the same file in SU10 beta?


Thanks for your help,

Richard

PS: here the link to the created flightplans (LOWW-LOWI with two custom waypoints, created in the latest SU10 beta build)

SU10
10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

MiGMan_Flight_Sim_Museum avatar image
MiGMan_Flight_Sim_Museum answered MiGMan_Flight_Sim_Museum commented

Hopefully this will be fixed ASAP. I alone have 15 commercial products based on .pln files and as you indicate there is a massive user base that relies on .pln files.

3 comments
10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

I'm happy to report that the plns I've tested thus far are working as expected.
0 Likes 0 ·
NAVData avatar image NAVData MiGMan_Flight_Sim_Museum commented ·

No, I can´t confirm this - Navigraph AIRAC 2209 installed, PLN file saved, PLN file loaded - same effect, custom waypoints are somewhere but not in place. Same test-scenario as in the initial posting.


Again, this happens ONLY in v1.27.21.0 and when you use our navdata package, not the stock data! In the latest previous version v1.26 (as I have shown in the initial posting), the PLN files were loaded also correctly with our navdata package.

So, we should give ASOBO time to check this - but this issue still exist also in the released version of SU10.

Cheers,

Richard


1 Like 1 ·
MiGMan_Flight_Sim_Museum avatar image MiGMan_Flight_Sim_Museum NAVData commented ·
Hi Richard,

Yes I agree 100%.

I should have clarified, I was only referring to .pln files loaded directly into the sim from the world map. And I have only tested a few locations.


1 Like 1 ·
EPellissier avatar image
EPellissier answered

Hi there,

This is being investigated on our side.

Best regards,

Eric / Asobo

10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

NAVData avatar image
NAVData answered NAVData edited

Thanks Eric - only just an idea:

Could it be, that we must re-build our BGLs again with SU10? Because in all test-cases, I have used the BGLs build with the current version 1.26 ... the xml-schema isn´t changed (at least for navdata) between the current version and SU10 but possible you have made some changes in the compiler?

That would explain, why the PLN files are working in the current version but not in the SU10beta and that the PLN files work with the stock data but not with our data in SU10 beta.

Cheers,

Richard

10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.