plane icon Welcome to Microsoft Flight Simulator’s SDK Q&A Platform!

You have questions regarding the SDK? DevMode Tools? SimConnect? You would like to submit an idea for future improvements, seek help or exchange knowledge? You’re in the right place.

Please take a moment to read the platform’s guidelines before you get started!

question

Sherv avatar image
Sherv asked FlyingRaccoon commented

Shadowing bug above wings

Hi team. I wanted to see if you are aware of a strange shadow effect above the wing root. Without giving away what we're working on here's a screen shot ( e. The model has no textures yet so this is not being caused by any reflections. I drew an arrow showing the direction of the sun. Based on the direction, this part of the wing should have no shadow at all.

bug.jpg

Thanks,

Sherv

aircraftlight
bug.jpg (18.3 KiB)
10 |10000 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

1 Answer

· Write an Answer
mattnischan avatar image
mattnischan answered FlyingRaccoon commented

That looks to me to be ambient occlusion, if I had to guess.

7 comments
10 |10000 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

Agreed.

@Sherv You can confirm that through the DevMode options menu and display only ambient occlusion

1626092044319.png

0 Likes 0 ·
1626092044319.png (170.9 KiB)
Thanks guys for the quick response. When I turn on AO, all I see is a white screen. I don't see anything where the shadow should be. Am I looking for anything specific? Thanks
0 Likes 0 ·

On the A320, AO will look like this:

1626167340494.pngYou can see the wing root is darker, just like in your screenshot.
This is visible even with the ambient occlusion graphics option set to off.

0 Likes 0 ·
1626167340494.png (126.4 KiB)
Sherv avatar image Sherv FlyingRaccoon ♦♦ ·

Ok gotcha. Not sure if I was clear on my original post, my model has no texture mapping at all. I am just exporting the mesh into the sim for analysis. In that case I would think the AO would just be all white like I was seeing? Thanks

0 Likes 0 ·
Show more comments

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.