plane icon Welcome to Microsoft Flight Simulator’s SDK Q&A Platform!

You have questions regarding the SDK? DevMode Tools? SimConnect? You would like to submit an idea for future improvements, seek help or exchange knowledge? You’re in the right place.

Please take a moment to read the platform’s guidelines before you get started!


Odog avatar image
Odog asked jackrosaymusic commented

Custom Object Appears in Object List But When Placed does not show.


I have just started today creating custom objects for my second scenery. I am familiar with the process but have just switched to the official blender exporter from Asobo. When I export an object with its textures - done the same way in any tutorial - the files correctly generate and the gITF preview works. The issue arises when I try to place the object in my scenery package. The object shows up on the object viewer, but when I place the object, all that shows is an empty box from the msfs dev mode GUI (see attached). Any recommendations? I have tried the old blender2msfs, different object shapes, cleaning the package, and getting rid of the assigned textures. When I build the package there are no errors or warnings associated with the object. All has been done with blender 3.1. microsoft-flight-simulator-130110-1-13-2023-9-08-5.png

10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

DORRAGER avatar image DORRAGER commented ·

When you added the model did you build the package and then reload the project file.

Only other thing did you check in the material section in MSFS material Params that there is no option to migrate textures for the model when using the official exporter. If this needs doing there should be a grey clickable box.

0 Likes 0 ·
Odog avatar image Odog DORRAGER commented ·

I rebuilt and reloaded the project file and the issue persists. I did have the migrate textures button visible, so I clicked it and repeated the object creation steps and placement but still to no avail. Do you have any other suggestions? What's funny is that any custom object I created a few months ago works perfectly fine but as soon as I re-export the object it stops working.

0 Likes 0 ·
DORRAGER avatar image DORRAGER Odog commented ·

Thats a shame erm. could post the screen shots for the set up of the official blender exporter within blender the multi exporter drop down box im on about.

You could also get hold off the ModelConverterX app its free. You load it up you can just drag and drop the generated gltf file into it and usually if it shows up fine on there it will work in MSFS.

0 Likes 0 ·

1 Answer

Odog avatar image
Odog answered jackrosaymusic commented
I did some testing by using my custom object in my older scenery and it shows up! It seems like the issue must be how I set up my Model Library and BGL file paths. It's funny because those paths were auto-generated from the simulator. I copied over the exact file paths from my old scenery in this one and it works!

I appreciate your help!

10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

jackrosaymusic avatar image jackrosaymusic commented ·
Hey Odog, I just came across the same problem with my project and can't figure it out. Could you explain how you fixed it with the file paths. Thanks
1 Like 1 ·
DORRAGER avatar image DORRAGER commented ·
Glad you found the reason.
0 Likes 0 ·

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 5 attachments (including images) can be used with a maximum of 19.1 MiB each and 23.8 MiB total.