plane icon Welcome to Microsoft Flight Simulator’s SDK Q&A Platform!

You have questions regarding the SDK? DevMode Tools? SimConnect? You would like to submit an idea for future improvements, seek help or exchange knowledge? You’re in the right place.

Please take a moment to read the platform’s guidelines before you get started!


For HUDs issues management, please read the article here !

question

rotornut44 avatar image
rotornut44 asked rotornut44 commented

Custom Aerials Overridden by Default Terrain

CGL Aerials compiled with the latest update will show at a distance while in the Scenery Editor, however once you zoom in, the default textures take over. This is if the project has been compiled, placed into the community folder and the scenery editor has been opened to edit the airport.

Normal behavior: The custom aerial should remain a higher priority than the default terrain.

Actual behavior: Custom aerial despawns as you zoom in.


Edited - Aug. 3

Leaving the compiled package in the generated "Packages" folder will allow the aerials to show in the editor. If these packages are removed from the folder, the aerials will unload from the editor, even if the aerials are located in the community folder.

scenerydefaultdevmodedevs
10 |10000 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

1 Answer

· Write an Answer
yorgosGK avatar image
yorgosGK answered rotornut44 commented

So I went to my exported airport after reading this to see if my CGL secondary aerials are in and they in fact are. They don't appear to be shifting in and and out like you reported based on zoom level.

Have you tried to actually export your package? Is it different in Dev mode vs export?

4 comments
10 |10000 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

The aerials appear just fine after you export the package and if you are just viewing them in the sim. The problem starts when you enter into dev mode. If your aerials are in the same package as your airport, once you open the airport in the scenery editor, the aerial begins to unload.


This problem only seems to persist with CGLs compiled after SU5, as I have a few that were exported with previous versions that don't have this issue. However as soon as they are recompiled, the above starts to happen.

0 Likes 0 ·

Unfortunately I have tried to replicate all of this in dev mode and I cant seem to "lose them". do you have a package in your community folder? I know this helps CGL to always "load" properly in dev mode.

0 Likes 0 ·
Yes, the package was built and put into the community folder. The sim was then restarted before entering into devmode. Once I get some time, I'll mess with one of my other packages and see if I can reproduce it there as well.
0 Likes 0 ·
Show more comments

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.