plane icon Welcome to Microsoft Flight Simulator’s SDK Q&A Platform!

Save the date ! On February the 9th, at 10:30am, we will be happy to meet you again for a live SDK Q&A ! You can already ask all your questions here on the forum.

You have questions regarding the SDK? DevMode Tools? SimConnect? You would like to submit an idea for future improvements, seek help or exchange knowledge? You’re in the right place.

Please take a moment to read the platform’s guidelines before you get started!


question

Cammac avatar image
Cammac asked boufogre commented

Jet engine cannot achieve over 100% N1.

Hi,

For the project I am working on TOGA thrust on an ISA day is about 104/108% N1. CLB thrust in the upper flight levels can be around 103%N1 and TOGA/MCT in the mid flight levels around 110%.

From what I can see so far I am unable to get the engines to achieve an N1 higher than 100% even when I have the correct N2_N1 tables inserted along with the below settings inserted into the engines.cfg.

high_n1=117

high_n2=110.5

max_n1_protection=117

max_n2_protection=110.5

What you can also see is the engine is making the correct rated thrust but at 100% N1 which of course should not be the case if TOGA is supposed to be 106%.

The knock on effect of this is climb and CRZ performance is substantially off and the engine can't reached the correct rated CLB or takeoff thrust setting.

Also if I set the above CFG settings to lower than 100% N1 then they are respected and the engines won't go over the set N1 limit so long as it's lower than 100% N1.


1634555669589.png


Steps to reproduce:

  • Select a Jet engine and set the high_n1= high_n2 max_n1_protection max_n2_protection to values of more than 100% or copy the settings I used above.
  • Set weather to ISA and no wind at sea level airport.
  • Increase power to TOGA and you will see a slight N1 overshoot to say 101% but it will slowly come back to 100% and you should see that at 101% it's creating over the max rated thrust.

Tested on both SU5 and SU6

Thanks again.

aircraft
1634555669589.png (729.2 KiB)
10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

FlyingRaccoon avatar image
FlyingRaccoon answered boufogre commented

Hello @Cammac

We were able to reproduce this issue and identify why it's happening.
We are working on a fix. No ETA yet as it needs to be properly tested and we want to make sure there are no regressions.

Regards,
ASOBO/Sylvain

1 comment
10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

Hello,


Any update on the fix?

Thank you!

0 Likes 0 ·
boufogre avatar image
boufogre answered boufogre commented

Hello,

Just to contribute to this problem, I think the cause is that the documentation mentions a linear interpolation to 100% N1, when it should be to the specified high N1 value. It should not be hard to fix, hopefully.

1638789121988.png
Another discovery I have made by experimenting is that the high N1 and high N2 values specified in the configuration file are corrected values, not actual values. The same is valid, according to my observations, for the N1 and N2 protections.


1638789121988.png (23.3 KiB)
1 comment
10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

Actually, I would like to correct myself. To conserve the logic of the tables where a throttle position commands a N2 value, which is then converted to a N1 value, the linear interpolation should be between idle N2 and high N2.
0 Likes 0 ·
boufogre avatar image
boufogre answered boufogre edited

Proof that N1 over 100% can be achieved using the use_commanded_Ne_table parameter:

1638877118982.png

However, it can be seen in the engines debug UI that the TComN1, which my guess is the commanded N1 from the formula is indicating 100%.


1638877118982.png (3.2 MiB)
2 comments
10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

Thanks for the post here. I was also able to get the engines over 100% N1 but they very slowly start to come back to the commanded 100% N1. For myself it tends to take about 10/20 seconds for it to get back to 102/101% N1 then it will settle on 100% eventually. As if a PiD controller or some kind is bringing it back to 100%. Do you also see this behaviour?

0 Likes 0 ·

Not if I set the use_commanded_Ne_table to 0, then the N1 can go and stay above 100%. Of course, you need to set the proper tables manually.

But if I set this parameter to 1, then yes, it will go above 100% but will always roll back to 100.

By the way, the screenshot was showing a static test, and stable N1.

0 Likes 0 ·

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 5 attachments (including images) can be used with a maximum of 19.1 MiB each and 23.8 MiB total.