plane icon Welcome to Microsoft Flight Simulator’s SDK Q&A Platform!

Save the date ! On February the 9th, at 10:30am, we will be happy to meet you again for a live SDK Q&A ! You can already ask all your questions here on the forum.

You have questions regarding the SDK? DevMode Tools? SimConnect? You would like to submit an idea for future improvements, seek help or exchange knowledge? You’re in the right place.

Please take a moment to read the platform’s guidelines before you get started!


question

vpilot avatar image
vpilot asked Ironpot commented

Issue with Painted Hatched Areas not being painted

Painted Hatched Areas not being painted after drawn. Also, once this happens regular painted lines are not drawn either and if any existing lines are deleted, these are visually still shown.

The workaround is to close the project and re open it.

scenerydefaultbughelp
10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

Ironpot avatar image
Ironpot answered

I thought it was just me and deleted my post because it seemed to self correct after I compiled and reloaded the project. The issue was exactly as you describe. However it has not returned after that incident. Make sure you do not have a single random taxiway point not connected. I did an believe is what may have caused the issue whilst adding a material.

10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

Ironpot avatar image
Ironpot answered Ironpot edited

Just confirming that this has now manifested itself again. Once an area is drawn, all User defined materials fail to render. If you rebuild the project and then click load BGL in the same session (to get rid of the PINK) MSFS goes into non-responding mode and only an enforced kill application will release it. Returning into the project, I can now see and modify the PaintedHashArea and other lines

I reopened the compiled project and added another PaintedArea and same thing. No lines. I saved and tried closing the project and MSFS is now hanging! So that workaround is not working either...

10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

vpilot avatar image
vpilot answered

It is still happening to me. Really difficult to work with these tools broken.

Has anyone from the official MS Team seen this thread?

10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

vpilot avatar image
vpilot answered vpilotfs commented

Anyone who can help with this?

2 comments
10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

I think they are aware of this and already fix It (but you know, fixed things are available only with standard updates, so we Will have to wait till febraury, maybe with tomorrow roadplan release we Will,hopefully, get info on a hotfix)


Look at the latest sdk update (18th november)


https://www.flightsimulator.com/november-18th-2021-development-update/

0 Likes 0 ·
I read the sim update but seems like a different issue. The problem we are having is the lines or areas are not being painted. The one described in the update makes the sim crash.
0 Likes 0 ·
vpilot avatar image
vpilot answered

is this being ignored?

10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

SonantAlpaca avatar image
SonantAlpaca answered

Hello,

Nope, we are aware of this issue and our developers are working on it.

They will let you know if they need more information to fix the bug.


10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

FlyingRaccoon avatar image
FlyingRaccoon answered FlyingRaccoon commented

@vpilot @Ironpot Can you guys confirm scrolling to zoom / unzoom and force LOD changes also updates the drawing?

2 comments
10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

Hi Sylvian, If I understand you correctly, Adding a PaintedHatchedArea with Edge_Service_Solid selected simply places an 'empty' area. Change angle to say -33 with .85 space and scrolling in/out with the mouse does not fill it in. If I save the scenery, no change. However, if I click on Project Editor tab (off the Scenery Editor tab) the PaintedHatchedArea disappears. Click back on the Scenery Editor tab and it re-appears but still with no content.

Clicking on Project Editor tab again and then build results in a clean build (with pink splattered everywhere an apron is). I usually then click on the BGL package and click Load in Editor but doing so causes a hang. I now have to kill MSFS. On re-opening the newly painted area exists

1638491075773.png

0 Likes 0 ·
1638491075773.png (2.9 MiB)
The pink issue is a different bug and happens when building a MaterialLib asset group. @Darwikey is on this one.


When I talk about scrolling in/out, I mean scrolling enough to have the terrain tile switch LODs. If that doesn't change anything, I'll let the dev working on this know.

0 Likes 0 ·
FlyingRaccoon avatar image
FlyingRaccoon answered Ironpot commented

Hello.

The issue has been reproduced as you describe it on a retail version and will be fixed with the next update.
The problem was also happening with Projected Meshes.

Regards,
Sylvain

1 comment
10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

Ok great. My version is STEAM
0 Likes 0 ·

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 5 attachments (including images) can be used with a maximum of 19.1 MiB each and 23.8 MiB total.