plane icon Welcome to Microsoft Flight Simulator’s SDK Q&A Platform!

Save the date ! On February the 9th, at 10:30am, we will be happy to meet you again for a live SDK Q&A ! You can already ask all your questions here on the forum.

You have questions regarding the SDK? DevMode Tools? SimConnect? You would like to submit an idea for future improvements, seek help or exchange knowledge? You’re in the right place.

Please take a moment to read the platform’s guidelines before you get started!


question

64_Bandmaster avatar image
64_Bandmaster asked Darwikey answered

Developer camera seems to be broken.

Hello,

I am by no means a developer, however I have been creating my own scenery for MSFS lately. After a clean re-install of both Windows and MSFS, the developer camera will not translate for me using ASWDRF keys as before. The in-game drone camera works just fine. I cannot seem to track down the problem, but I cannot continue without the developer camera working. Any ideas?


Thank you

default
10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

runwaypimp avatar image
runwaypimp answered

Same for me. The problem only starts once a project is loaded.

Rotation works but not any sort of movement over the ground.

Toggling madly between slew, dev cam, internal and external cameras, can rarely free it up.

Might be some sort of focus issue. Keys and controllers both don't work.

10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

mamudesign avatar image
mamudesign answered runwaypimp commented

Go into the new menu developer camera settings and bring back the translation value to the desired speed (at least a positive value).


If the Asobo team Is reading this:

When the devmode.xml gets regenerated (After deleting It for any reason ), the translation value goes to a negative value, another Little and Easy fix for your backlog



1 comment
10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

I can confirm this works. Thanks Mamu. My dev camera was set to -100!

Slew mode is still locked up however but I can work without it.

0 Likes 0 ·
SonantAlpaca avatar image
SonantAlpaca answered

@Darwikey can you please check this out?

Thanks!

10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

virtuali avatar image
virtuali answered

I might add a small remark: it seems the translation value is saved when saving the settings, but the rotation value is not.

10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

Darwikey avatar image
Darwikey answered

Thanks for all your feedbacks! It has now been fixed (fix available in the next SU)

Xavier

10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 5 attachments (including images) can be used with a maximum of 19.1 MiB each and 23.8 MiB total.