plane icon Welcome to Microsoft Flight Simulator’s SDK Q&A Platform!

We prepared 3 new YouTube tutorials about Audio! They are available here.
You have questions regarding the SDK? DevMode Tools? SimConnect? You would like to submit an idea for future improvements, seek help or exchange knowledge? You’re in the right place.

Please take a moment to read the platform’s guidelines before you get started!


question

DrzewieckiDesign avatar image
DrzewieckiDesign asked devmode_player edited

LODs of animated objects are not synced

Hi.

I am not sure if this has been reported, but LODs of animated objects are not synchronized with each other. It means, that when switching from one LOD to another, the animation is usually started from the beginning which makes the object "jump" to a different position. Some simple objects can be done with no LODs however more complex - can't. Would it be possible to fix this in the future?

Here is an example. The plane in the middle is animated. High LOD:

anime1.jpg

Switches to low LOD and instantly changes position to the beginning of the animation:

anime2.jpg


scenerydevmodeanimation
anime1.jpg (965.9 KiB)
anime2.jpg (956.8 KiB)
4 comments
10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

I can confirm, this is long-standing core issue came out of SU5 and its new xbox LOD system. Unfortunately it affects on static simobjects as well. I see no moves to fix it

1 Like 1 ·
Hello @DrzewieckiDesign

What type of object is this?
Is this a scenery object from a ModelLib or a SimObject?

0 Likes 0 ·
DrzewieckiDesign avatar image DrzewieckiDesign FlyingRaccoon ♦♦ ·

This is a ModelLib object with animation.

0 Likes 0 ·
Boris_ avatar image Boris_ ♦ DrzewieckiDesign ·

Hello @DrzewieckiDesign ,

As we need to make some tests, can you provide us your project source or at least the objects with which you have the issue (the moving aircraft for example) please (WeTransfer/Google Drive/ One Drive..)..
(You can select the privacy options bellow the submit button)

Best Regards,

Boris

1 Like 1 ·
FlyingRaccoon avatar image
FlyingRaccoon answered devmode_player edited

Hello @DrzewieckiDesign

Some background to explain this behaviour.
There is an optimization process on animations; as you go further away from an object, some keyframes are skipped and when the bounding sphere size is less than 1% in screen size, the animation is no longer updated.

In most cases, this is not an issue as the animated parts are small but in cases like yours, this becomes visible.
A workaround is to artificially increase the bounding sphere size so that this process happens further away from the object. This can be done by adding invisible geometry in your model (creating an invisible box for example).

Regards,
Sylvain

3 comments
10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

FlyingRaccoon,

Could you please to include the information above to the SDK documentation. It would help developers do not waste time to find out that 'problem' is just design choice

thanks

0 Likes 0 ·
Yes @devmode_player, @Nocturne has already added a note in the animation section. It will be shown in the next doc build.
0 Likes 0 ·
devmode_player avatar image devmode_player FlyingRaccoon ♦♦ ·

Can you ask engine developers about optimization on IK chain animation used in jetways. It's not key based animation and currently it acts weird when switching from LOD to LOD

thanks

0 Likes 0 ·
DrzewieckiDesign avatar image
DrzewieckiDesign answered

Hi.

Is there any chance to have this issue investigated by Asobo? It would be great to have it fixed for animated objects.

10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

DrzewieckiDesign avatar image
DrzewieckiDesign answered DrzewieckiDesign edited

Hi.
After the latest update, the issue seems to be fixed although a re-export of the particular animated object is required.

10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 5 attachments (including images) can be used with a maximum of 19.1 MiB each and 23.8 MiB total.