plane icon Welcome to Microsoft Flight Simulator’s SDK Q&A Platform!

You have questions regarding the SDK? DevMode Tools? SimConnect? You would like to submit an idea for future improvements, seek help or exchange knowledge? You’re in the right place.

In the upcoming flighting, we've changed the behaviour of the content.xml file. If your addon uses this file, please read this article!

Please take a moment to read the platform’s guidelines before you get started!


question

virtuali avatar image
virtuali asked Alpengreis edited

Possible BUG with deleteAllJetways

I've observed what looks like a bug with the DeleteAirport, specifically the deleteAllJetways flag, but it's possible other flags in the DeleteAirport might be affected too.

If a replacement airport that has custom Jetways in the Community folder replaces a standard default airport with no "handcrafted" version, everything works as expected: the new airport can use the deleteAllJetways flag, and its custom jetways will show with no issues.

If the airport to be replaced has an "handcrafted" version in the Official folder ( doesn't matter if it's encrypted, like KSFO or not, like KJFK or KDFW ) which ALSO use the deleteAllJetways flag itself so, basically, we already have two versions of the airport and are adding a 3rd, the deleteAllJetways flag works only the first time the new airport is added. On every subsequent session of the sim, the replacement jetways which showed up the first time, can't be seen anymore. The Console doesn't report any problems, and confirms the add-on package has been loaded successfully in all sessions.

The problem can be fixed by manually removing the CONTENT.XML. As soon the file is removed to be regenerated, the new jetways shows up, but only for that first session. It's possible to go back to the Main menu, choose another airport, go back there and jetways are still showing. Everything works, provided the simulator is not closed. On the next session, the new jetways are not loaded, so a new cycle begins, requiring removing the CONTENT.XML again, which always fix the problem.

It doesn't seem a scenery priority problem. In all cases, the CONTENT.XML always had the new airport in the last line. There are no other add-ons in the Community folder and, when the CONTENT.XML is regenerated, the new one is byte-by-byte identical to the previous one that didn't work after the first time.

Removing the SceneryIndexes folder doesn't seem to make any difference, and it doesn't seem to change if *only* the CONTENT.XML is recreated, as long the installed packages are the same. The one and only thing that always solves the problem is removing the CONTENT.XML, which fixes the issue, but just for one session.

It seems the loading order works differently on a session where a CONTENT.XML is being recreated from scratch, compared to a session in which it was already present.

Another thing that fixes the issue, is manually editing the 2nd "handcrafted" .BGL, to unset the deleteAllJetways at the binary level, making the new replacement file the only .BGL that replaces jetways on that airport, which falls back in the first case, where everything's working if only one .BGL use the deleteAllJetways flag, which is the usual situation of default airports with no enhanced version.

I even tried replacing the entire airport, basically creating a clone of the default airport, with every element present ( taxiways, parkings, runways, ils, jetways, frequencies ) and the behaviour is still the same: custom jetways still don't show, except for the first session when a new CONTENT.XML is created, but not in subsequent sessions.

scenery
1 comment
10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

FlyingRaccoon avatar image FlyingRaccoon ♦♦ commented ·
@Darwikey FYI
0 Likes 0 ·
FlyingRaccoon avatar image
FlyingRaccoon answered virtuali commented

Hello @virtuali

We were able to reproduce the problem that actually occurs with all delete commands.
This will be investigated.

Regards,
Sylvain

1 comment
10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

virtuali avatar image virtuali commented ·
Thanks a lot for looking into it, let me know if you need any further info.
0 Likes 0 ·
virtuali avatar image
virtuali answered

I'm bumping this up to report the following:

It seems this problem affects Projected Meshes as well. But, instead of being fixed by removing the Content.xml before each start ( which fixes the non-working deleteAllJetways command ), it seems to be more permanent.

In fact, what's the proper method of Excluding a Projected Mesh, assuming it's even possible ?

Regardless of the order in the Content.XML file, if two sceneries for the same area both have Projected Mesh, both will show up.

The scenery which is supposed to exclude the one below already has both Exclusion Rectangles with excludeAllObjects and Exclude Polygons as well. No issues of double objects, only the Projected Meshes are duplicated.

10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

virtuali avatar image
virtuali answered FlyingRaccoon commented

I'm bumping this again: has these two issues been fixed for SU9 ?

- The multiple Delete commands not working after the first scenery that deleted something UNLESS the CONTENT.XML is deleted.

- The inability to exclude a scenery that use a Projected Mesh

1 comment
10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

FlyingRaccoon avatar image FlyingRaccoon ♦♦ commented ·
@virtuali No, this is not fixed in SU9 yet.

Regarding projected meshes, we'll add an option for it in Exclusion Rectangles.

Regards,
Sylvain

0 Likes 0 ·
Alpengreis avatar image
Alpengreis answered Alpengreis edited

Is that fixed now in SU10?

Nobody here to answer that?

10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 5 attachments (including images) can be used with a maximum of 19.1 MiB each and 23.8 MiB total.