plane icon Welcome to Microsoft Flight Simulator’s SDK Q&A Platform!

You have questions regarding the SDK? DevMode Tools? SimConnect? You would like to submit an idea for future improvements, seek help or exchange knowledge? You’re in the right place.

In the upcoming flighting, we've changed the behaviour of the content.xml file. If your addon uses this file, please read this article!

Please take a moment to read the platform’s guidelines before you get started!


question

Sasa avatar image
Sasa asked Sasa answered

SU8 Beta - Sound volume bug

Hi!

There's a problem with legacy sounds that is reproducible in SU8 beta only (I have both versions installed and checked it's SU8 only).

In my EGAR Rothera scenery (see Marketplace) most simobjects on the ground have legacy sounds attached. Since SU8 all of them are audible at almost full volume once the simobjects are loaded - but only when inside the cockpit. Developer camera and spotplane view are fine.

Here's an example:

[FLTSIM] 
product_code=FSIM

[SOUND_ENGINE]
number_of_engines=1
eng1_combustion=COMBUSTION.1.00

[COMBUSTION.1.00]
filename=Tester_LS_Bus001
flags=0
viewpoint=1
rparams=0.023000,1.000000,0.315000,1.084000
vparams=0.000000,84.000000,0.111000,84.000000,0.194000,21.600000,0.347000,0.000000,0.671000,0.000000,0.727000,0.000000,0.787000,0.800000,0.894000,0.000000
full_scale_distance=10
link=COMBUSTION.1.01
ConePitch=0.000000
ConeHeading=0.000000
InsideConeAngle=360
OutsideConeAngle=360
OutsideConeVolume=10000

[COMBUSTION.1.01]
filename=Tester_LS_Bus001
flags=0
viewpoint=1
rparams=0.127000,0.741000,0.993000,1.072000
vparams=0.060000,0.000000,0.130000,17.600000,0.171000,84.000000,0.579000,86.000000,0.998000,100.000000,1.000000,100.000000,1.000000,100.000000,1.000000,100.000000
full_scale_distance=15
link=COMBUSTION.1.02
ConePitch=0.000000
ConeHeading=0.000000
InsideConeAngle=360
OutsideConeAngle=360
OutsideConeVolume=10000

[COMBUSTION.1.02]
filename=Tester_LS_Bus001
flags=0
viewpoint=2
rparams=0.023000,1.000000,0.315000,1.084000
vparams=0.000000,84.000000,0.111000,84.000000,0.194000,21.600000,0.347000,0.000000,0.671000,0.000000,0.727000,0.000000,0.787000,0.800000,0.894000,0.000000
full_scale_distance=13
link=COMBUSTION.1.03
ConePitch=0.000000
ConeHeading=0.000000
InsideConeAngle=360
OutsideConeAngle=360
OutsideConeVolume=10000

[COMBUSTION.1.03]
filename=Tester_LS_Bus001
flags=0
viewpoint=2
rparams=0.127000,0.741000,0.993000,1.072000
vparams=0.060000,0.000000,0.130000,17.600000,0.171000,84.000000,0.579000,86.000000,0.998000,100.000000,1.000000,100.000000,1.000000,100.000000,1.000000,100.000000
full_scale_distance=17
link=COMBUSTION.1.06
ConePitch=0.000000
ConeHeading=0.000000
InsideConeAngle=360
OutsideConeAngle=360
OutsideConeVolume=10000

When removing the "viewpoint=1" (=cockpit) entries, the problem is gone:

[FLTSIM] 
product_code=FSIM

[SOUND_ENGINE]
number_of_engines=1
eng1_combustion=COMBUSTION.1.02

[COMBUSTION.1.02]
filename=Tester_LS_Bus001
flags=0
viewpoint=2
rparams=0.023000,1.000000,0.315000,1.084000
vparams=0.000000,84.000000,0.111000,84.000000,0.194000,21.600000,0.347000,0.000000,0.671000,0.000000,0.727000,0.000000,0.787000,0.800000,0.894000,0.000000
full_scale_distance=13
link=COMBUSTION.1.03
ConePitch=0.000000
ConeHeading=0.000000
InsideConeAngle=360
OutsideConeAngle=360
OutsideConeVolume=10000

[COMBUSTION.1.03]
filename=Tester_LS_Bus001
flags=0
viewpoint=2
rparams=0.127000,0.741000,0.993000,1.072000
vparams=0.060000,0.000000,0.130000,17.600000,0.171000,84.000000,0.579000,86.000000,0.998000,100.000000,1.000000,100.000000,1.000000,100.000000,1.000000,100.000000
full_scale_distance=17
link=COMBUSTION.1.06
ConePitch=0.000000
ConeHeading=0.000000
InsideConeAngle=360
OutsideConeAngle=360
OutsideConeVolume=10000

Of course it would be preferable if the bug would be removed in MSFS itself instead of having to push out yet another fix. It surely wasn't intentional that outside sounds play louder inside the cockpit than outside. :)

Plus it would be nice to still being able to hear a few sounds inside the cockpit at normal volume as was the case before.

scenerysoundsu8
10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

FlyingRaccoon avatar image
FlyingRaccoon answered

Hello @Sasa

Actually, this is the result of a bug fix where the legacy sounds were never played in cockpit view.
Now they're played but you seem to be right and there is an issue with sound not being attenuated over distance.
Developers are looking at it. The time for us to identify and fix it, I doubt it'll make it into SU8 final build. SU9 is the realistic target.

This is also why we strongly encourage using Wwise. We barely have any content using the legacy workflow and it's way more prone to bugs and errors from our part.

Thank you for reporting the problem and our apologies for the inconvenience it's causing

Regards,
Sylvain

10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

Sasa avatar image
Sasa answered

Thank you, Sylvain! That's indeed a funny bug - I didn't even notice! :)

Will deactivate the "viewpoint=1" sounds for now and see how soon I can get my first Wwise sounds running.

10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 5 attachments (including images) can be used with a maximum of 19.1 MiB each and 23.8 MiB total.