plane icon Welcome to Microsoft Flight Simulator’s SDK Q&A Platform!

You have questions regarding the SDK? DevMode Tools? SimConnect? You would like to submit an idea for future improvements, seek help or exchange knowledge? You’re in the right place.


Please take a moment to read the platform’s guidelines before you get started!


question

Ironpot avatar image
Ironpot asked Marijnvc answered

Constant CTDs in DEV after SU8 when moving apron or taxiway points

I have STEAM version and successfully used SU8 in BETA to continue editing my airport. Since the "everyone" release to 1.23.12.0 and latest SDK 17 I am forced to save my scenery after EVERY step I do - placing or moving something. I get CTDs basically when I move points on an apron or taxiway. They seem to accumulate in number (the points) and then after so many movements I get a CTD. I've turned off the dump file because I received at least 18 in a couple of hours editing.

Is this known? How many dump files do you want. Basically, this is not allowing much progression in development. Placing an apron is OK - moving points is not. Sometimes after restarting, I simply get a CTD without even getting to the airport.

devmodectd
10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

Claviateur avatar image
Claviateur answered

I will try dev mode in SU8 but in the SU7 I had the similar CTDs as well as others here and we were told that this is a known issue that the engine team are investigating. Not related to Dev Mode.

However, I am curious to open MSFS and try Dev Mode in SU8 to see.

10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

Claviateur avatar image
Claviateur answered Claviateur commented

MSFS just CTD in Dev Mode when I was only creating a new scenery Package... Still unstable unfortunately.

4 comments
10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

Could you explain what you did exactly so that we can try to reproduce the issue internally?

Best regards,

Eric / Asobo

0 Likes 0 ·
Claviateur avatar image Claviateur EPellissier ♦♦ ·

Hello Eric,

I tried to reproduce every scenario but unfortunately there is not one I can reproduce. I get a Dev Mode CTDs since SU7 (After not using Dev Mode for a while).

The one reported here was when I used the Simple Scenery from the Samples and tried to modify the names and add packages etc. Other times if I am working on a scenery and after moving some polygon or apron points, changing material or any basic interaction like these.

And I also did some tests using very basic scenery, no complex 3D elements there. Only aprons, runways and a couple of polygons.

I will try again but unfortunately there is not one repetitive pattern I can reproduce and report.

Merci!

0 Likes 0 ·
Claviateur avatar image Claviateur EPellissier ♦♦ ·

For example, I created, once again a scenery from scratch, in scenery Editor, added a polygon and went to save the shape file, so I navigated to the folder to save the shape file, then typed the name and hit save... MSFS crashed to desktop

So there is no constant pattern or scenario. It could be any simple interaction that results in a CTD.

0 Likes 0 ·
Claviateur avatar image Claviateur EPellissier ♦♦ ·
Today I gave it another try. I opened the simple scenery test project and I was deleting a package and got CTD.
0 Likes 0 ·
WildLynxAir avatar image
WildLynxAir answered EPellissier commented

I also have exactly the same problem. Impossible to do any serious work after SDK 0.17. CTD guaranteed. Community empty, uninstalled and reinstalled the SDK, no difference.

1 comment
10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

Just in case you didn't read that in another thread: the SDK and the DevMode are unrelated - sim crashes (which may be due to the DevMode itself or other parts of the sim) will never be fixed by SDK updates.

Best regards,

Eric / Asobo

1 Like 1 ·
Ironpot avatar image
Ironpot answered Ironpot commented

Hello @Boris_ Have you overlooked this or is it known and fixed?

4 comments
10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

Hi @Ironpot ,

We are still investigating, sorry for the delay.

Can you send us a recent Dump file that was generated with the CTD you had (the link in the other post is expired) ?
Thanks,

Regards,
Boris




0 Likes 0 ·
Hi Boris,

I removed that dump. This is a new issue to that. I’ll send tomorrow. As described, moving taxi points or apron points or even manipulating an apron with a material in it like a parking number causes a CTD. It seems like you move so many points and then a CTD. Occasionally MSFS will hang and I have to force the crash. Will try and place 2 dumps for you with a comment.

This was NOT happening with the SU8 Beta and SDK16. When SU8 was released and I updated SDK17 the CTDs started on same project. Is STEAM version

0 Likes 0 ·
Hi Ironpot, can you also give us your hardware configuration ?

Regards,

Xavier

0 Likes 0 ·
Show more comments
r2b2nz avatar image
r2b2nz answered Ironpot edited

I've been having similar issues with random CTDs especially when moving aprons or taxiways. Interestingly I tried switching to DX12 and so far (touch wood) haven't seen any CTDs. Obviously it might just be co-incidence.

4 comments
10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

I’ve provided the guys with dump files. I’m already on Dx12 so it might be coincidence as you said. Hopefully they do actually find a cause so it can be fixed.
0 Likes 0 ·
I am wondering how others are able to create, compile and release their scenery. It is certainly not happening with everyone.


I just want to place a 3D helipad platform in a spot and add a couple of polygons and it's been since SU7 that I try to do that with no success.

0 Likes 0 ·

Based on Ironpot's response, I thought I'd give switching back to Dx11 a go and found that it seemed happier than when I previously had switched to Dx12. If you haven't already, I'd perhaps try switching to Dx12 and then if that's happyish try switching back to Dx11 to see if it helps.

Might just be one big co-incidence again but I wonder if switching between Dx11/Dx12 clears out or regenerates something which is helping to lead to the CTD?

0 Likes 0 ·
Show more comments
Claviateur avatar image
Claviateur answered

I noticed that if I start the project in Airport Design Editor (ADE Alpha version for MSFS) and then open it in MSFS Dev mode, I can resume work in Dev Mode without CTDs. I did this for 2 test projects and so far so good.

ADE creates automatically the structure of the project (folders) as we enter the basic information.

And I am using DX11 here.

No idea why ADE initial project values and structure work in Dev Mode whereas the new project initiated in Dev Mode result in random CTD following basic naming input or polygon edit etc.

10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

Ironpot avatar image
Ironpot answered Claviateur commented

I have done this too, starting some projects in ADE with 2way edit on. However there comes a point when you can no longer edit in ADE because the Alpha version drops things because it’s not supported (which Jon the author, is aware of). Having said that, I still get CTDs in DEV from such a project and I assume it’s because the project gets more complex and not to do with the folder structure. Because I get crashes when moving materials in aprons and taxi points etc I think it’s more related to GPU. Whilst switching to DX12 appears to have resolved the issue, movement in the DEV window is sluggish and the camera sometimes zooms in/away etc when using ALT/mouse. I am still doing testing in the DX11 space

1 comment
10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

In my case, I just create a project and that's it, I close ADE and open it in MSFS Dev Mode.

But probably it was a coincidence in my case to not have any more CTDs. I will try again and see

0 Likes 0 ·
SJK91 avatar image
SJK91 answered

Same here. Start working on my scenery for 20/25 min then ctd. Mainly aprons and painted lines. As stated above this started with su8 and sdk 0.17 . I get the "standard 0xc0000005 or whatever access violation error.

I run a 2tb samsung 970evo

32gb gskill trident 3600mhz ram

Asus prime x470 pro mobo

Evga gtx 1080 ti sc2 gpu

Corsair rm 850 psu

Ryzen 2700x cpu

10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

Marijnvc avatar image
Marijnvc answered Marijnvc commented

Hi, is there a fix for this? I'm stuck on my project with about 99% done. It was fine this morning, even when I revert to previous back-ups it doesn't solve it.

10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

Marijnvc avatar image
Marijnvc answered

Seem to have found a way, now 1hour in smashing aprons all over the place and still there, not sure if this is known:

Turn off Hardware accelerated GPU scheduling in windows Graphic settings (if you got that)
Use DX12 and low settings

10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 5 attachments (including images) can be used with a maximum of 19.1 MiB each and 23.8 MiB total.