plane icon Welcome to Microsoft Flight Simulator’s SDK Q&A Platform!

You have questions regarding the SDK? DevMode Tools? SimConnect? You would like to submit an idea for future improvements, seek help or exchange knowledge? You’re in the right place.


Please take a moment to read the platform’s guidelines before you get started!


question

ModelMuncher avatar image
ModelMuncher asked ModelMuncher answered

Autopilot Altitude Capture

Seriously guys .. How do you get the AP to capture an Altitude using VS mode ?
Scenario
AP - CAP140
Altitude knob set to 5000 Feet
Vertical speed mode set for 1000 FPM
At 4000 feet AP Gives announcement
at 5000 Feet it just keeps climbing

Should it actually capture the target Alt ?
If so How do we set it up ?

Many thanks

aircraftflightmodelhelp
10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

ModelMuncher avatar image
ModelMuncher answered

bump anyone please ?

10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

Simbol avatar image
Simbol answered

Have you adjusted the Autopilots PIDs? you have to configure it so it predicts and starts capturing the alt.

Have a look at your autopilot PIDs values

S.

10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

ModelMuncher avatar image
ModelMuncher answered

No, I'm pretty certain its not PIDS, because when selecting ALT HOLD BUTTON, the Autopilot Immediately stops its climb/descent and "Holds" Altitude very well as I would expect it to do when the Target Altitude (set on the knob) is reached

I would suggest that in vs Mode it would appear that any TARGET ALTITUDE set on the knob is just ignored


10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

boufogre avatar image
boufogre answered

Hey,

Just noticed this, buried in the release notes of the latest SDK:
1647086440098.pngThere is a new parameter in systems.cfg, [AUTOPILOT] section:
no_alt_capture_in_vs_mode

Check if you have it in your systems.cfg, and set it to 0.

That might solve your problem.


1647086440098.png (53.3 KiB)
10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

ModelMuncher avatar image
ModelMuncher answered

Nahh.. just tried this with no effect ..

pretty sure the ASOBO KAP140 is Bugged
The ALT ARM Button shows VS mode toggle :(

10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 5 attachments (including images) can be used with a maximum of 19.1 MiB each and 23.8 MiB total.