plane icon Welcome to Microsoft Flight Simulator’s SDK Q&A Platform!

You have questions regarding the SDK? DevMode Tools? SimConnect? You would like to submit an idea for future improvements, seek help or exchange knowledge? You’re in the right place.


Please take a moment to read the platform’s guidelines before you get started!


question

DrzewieckiDesign avatar image
DrzewieckiDesign asked FlyingRaccoon commented

Whole buildings appearing white in snow conditions

Hi.

I wonder if there is a solution to whole [custom] buildings appearing white from a distance in snow conditions? This issue has been there for some time already. Is this something that can be fixed?


0-02-05-08ac5fe6d158a4612612ea2d9ba8ba903022218ea0.jpg0-02-05-f9726cef419aaa7015667608debff3cc3b4713c199.jpg

I mean - not only roofs but walls too. As soon as snow coverage becomes 0, everything gets back to normal.

scenerydefaultdevmode
10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

DrzewieckiDesign avatar image
DrzewieckiDesign answered DrzewieckiDesign rolled back

@Darwikey @FlyingRaccoon
I am just wondering if this is a known issue... since it has been there for at least a year but maybe even since the introduction of the snow altogether.

10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

FlyingRaccoon avatar image
FlyingRaccoon answered

Hello @DrzewieckiDesign

When your buildings are showing this issue, can you:
- take a picture after enabling the Options -> PBR Channel -> Normals(world) and show it here
- force the active LOD to higher detailed LODs using the "Debug LODs" tool and see if this has an influence

Regards,
Sylvain

10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

DrzewieckiDesign avatar image
DrzewieckiDesign answered FlyingRaccoon commented

Hi @FlyingRacoon.

Here are the pictures:

https://ibb.co/njy9mcT

https://ibb.co/HxYD8RD

https://ibb.co/k8hVpqB

3 comments
10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

Ok, wrong lead then :/

Can you send us your package or tell us where you see it if this also happens with Asobo content?

Thanks

0 Likes 0 ·
DrzewieckiDesign avatar image DrzewieckiDesign FlyingRaccoon ♦♦ ·
Well, we see this in many custom-made areas but not with auto-generated buildings.


Can LOD settings influence that? If so - how? The mentioned models have one LOD.

0 Likes 0 ·
If some LOD were having wrong normals, it could cause this but this is not happening in your case.

I can't really tell much without checking a package that produces the issue.

0 Likes 0 ·

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 5 attachments (including images) can be used with a maximum of 19.1 MiB each and 23.8 MiB total.