plane icon Welcome to Microsoft Flight Simulator’s SDK Q&A Platform!

You have questions regarding the SDK? DevMode Tools? SimConnect? You would like to submit an idea for future improvements, seek help or exchange knowledge? You’re in the right place.

In the upcoming flighting, we've changed the behaviour of the content.xml file. If your addon uses this file, please read this article!

Please take a moment to read the platform’s guidelines before you get started!


question

morganthomas757 avatar image
morganthomas757 asked DORRAGER answered

Severe FPS degradation in DevMode

Hi all,

Over the last 3 or 4 months I have been getting absolutely awful FPS stutters while editing my Scenery in DevMode. I build the package in-sim and Load into the Editor, but the FPS issues persist even when a copy of the built package is present in my community folder. I have a really powerful system with a Ryzen 9 5900X and RTX 3080 along with 32GB RAM so there is absolutely no reason why my FPS should be this poor. I get 60+ FPS at 1440p Ultra when not editing my scenery, but this current stuttering makes my project absolutely unusable to edit.

Unfortunately I can't pinpoint the exact time when this started happening, and I have done a full sim reinstall and SDK reinstall since. I'm at my wit's end quite frankly, as making my scenery just isn't fun anymore when dealing with these massive stutters.


scenerydevmode
10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

HybridNZ avatar image
HybridNZ answered

I just want to add it seems this has been fixed in SU9 beta. The overall performance is a lot lot better.

10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

WombiiActual avatar image
WombiiActual answered WombiiActual edited

I've been having the same issue. Even on smaller projects. It's so painful trying to edit sceneries when it's dropping to single-digit FPS (spiking to over 300ms mainthread) and often just registering every third mouseclick for everything I'm trying to do. Exiting the project editor, going back to main menu and restarting the flight does not clear it up. The issue persists until I restart the simulator which clears it up for me. It then starts happening again 1-10 minutes after I load a scenery project again.

10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

ZdenniZ avatar image
ZdenniZ answered

Same thing here. Drastic decrease in perf over time when editing airport.

10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

morganthomas757 avatar image
morganthomas757 answered

@WombiiActual exactly the same here. Editing my scenery currently with this issue makes it practically unusable. Not sure why more people aren't making noise about this as how are other devs coping!?

10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

StephB2i2L avatar image
StephB2i2L answered

I was starting to think it was only me but actually you confirm this is a somewhat wide spread issue.

BTW, at least one other topic is open on that issue https://devsupport.flightsimulator.com/questions/6555/performance-drops-as-we-work-in-dev-mode-su8.html

10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

HybridNZ avatar image
HybridNZ answered HybridNZ edited

Yes, the more 'stuff' you have in your scenery, especially in scenery editor mode .. give it about 20 mins and you have to restart the Sim the FPS is so bad. There were some improvements when the exporter assigned random collision faces to objects bug was fixed in SU8 and that did help a little bit, but the overall FPS drop issue is still there. It doesn't require long flight to find it, only work in a complex airport in the sim for 20-30mins and you'll have the issue show itself.
We can confirm its been an issue since SU6 as well and its 100% repeatable (I restart about 5-6 times a night)

PS Original Poster, in your video is what I see after about 15mins, I find pointing the camera straight down and flicking between scenery and material modes helps but it's only temporary as it loads and unloads the scenery editor overlays.

10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

Dav3.- avatar image
Dav3.- answered Dav3.- commented

I can't even place objects since is not loading the Assets, it is that bad.

Please try to address it as soon as possible ... Thanks

1649022000152.png


1649022000152.png (552.4 KiB)
2 comments
10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

I think that's a different issue of the model loading but not displaying. You can usually get it to display by clicking on the material editor and then jumping back to the scenery editor to force a scene to reload. No ideal but it works at least.

1 Like 1 ·
I'll try! Thanks!
0 Likes 0 ·
Claviateur avatar image
Claviateur answered

Same here. It starts smooth and then performance decreases over time... Sometimes it results in a CTD after a point when Dev Mode would become very slow and unusable.

10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

SonantAlpaca avatar image
SonantAlpaca answered Viktoren69 commented

Hello,

Yes, fixes were made on this specific topic for the SU9 Beta. Would it be possible for the other people who reported the issue to confirm that it's fixed on your end as well?

Thanks!

1 comment
10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

I am still having this issue even after SU9 with SDK 0.18 while editing the airport. If placing objects around the performance is good.
0 Likes 0 ·
StephB2i2L avatar image
StephB2i2L answered

After updating to SU9, the FPS degradation issue seems gone.

I can even potentially see better performances.

Thanks!

10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 5 attachments (including images) can be used with a maximum of 19.1 MiB each and 23.8 MiB total.