plane icon Welcome to Microsoft Flight Simulator’s SDK Q&A Platform!

We prepared 3 new YouTube tutorials about Audio! They are available here.
You have questions regarding the SDK? DevMode Tools? SimConnect? You would like to submit an idea for future improvements, seek help or exchange knowledge? You’re in the right place.

Please take a moment to read the platform’s guidelines before you get started!


question

WildLynxAir avatar image
WildLynxAir asked Boris_ commented

Problem with the Vector Placement Tool

Should the Vector Placement toll work fully in SU9/SDK0.18? I have made a 2m long simple wooden fence and placed it in my scenery using Vector Placement and three points, with a 90 degree angle at the midpoint. The fence fills up and shows fine in Dev Mode while the project is open. It builds without errors. But then in the sim (after restart and not in Dev Mode) the fence is not there. And further - as long as the fence is in the project I get an immediate CTD when returning from a flight to the Main Menu - 100% of time, regardless of using Dev Mode or not...

scenerydevmodectdsu9
10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

Boris_ avatar image
Boris_ answered

Hello @WildLynxAir ,

Is is a custom 3d model ? If yes, do you have the same behavior when replacing your asset with a fs-base scenery object ?

Can you send us a full dump file please ? See section 2 and 3 here


Regards,
Boris

10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

WildLynxAir avatar image
WildLynxAir answered

Yes, it is a custom model. Have to try with a fs-base object!


10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

mamudesign avatar image
mamudesign answered mamudesign edited

The same behaviour happens also in the SU9 official stable


I guess the VectorPlacement should return back to alpha, the following is using fs-base objects



screenshot-402.jpgwith the project open, even without loading
in the scenery editor, feels ok, but compiling:

screenshot-401.jpglast lod is also loaded in the air, on the top of lod0


screenshot-403.jpgfence04 has a single lod, lets load it in the air!



screenshot-404.jpgtarp and simple fence have multiple lods


Worst:

like @WildLyinxAir (why can't we tag someone else..?)

Loading an airport where a vectorplacement is used, returning in main menu will CTD, guarantee


a simple project (stripping down modellib)

LIGC-Crevalcore.zip

and full

https://drive.google.com/file/d/1kQRWtS639XPIT2JUhvp6qNeatl_QC5fY/view?usp=sharing


screenshot-402.jpg (954.0 KiB)
screenshot-403.jpg (962.8 KiB)
screenshot-404.jpg (963.5 KiB)
screenshot-401.jpg (1.2 MiB)
ligc-crevalcore.zip (46.0 KiB)
10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

WombiiActual avatar image
WombiiActual answered WombiiActual edited

Yeah, I'm sad after finally getting to try this. It's breaking in interesting ways.

Looks perfectly fine in project editor even without loading in scenery editor. This is using the shortest version of fence_grilling04 in fs-base.

screenshot-2022-04-27-043646.jpgscreenshot-2022-04-27-043628.jpg


This is what it looks like in the sim with the scenery installed. The first picture shows Fence A on the left side of the road and Fence B on the right side of the road. The second picture shows more of Fence A.

Fence A (left) is showing double with one part correctly following the ground and one part being completely straight with one end floating and the other end under ground.

Fence B (right) is only showing one part. Completely straight. One end floating and the other end under ground.

screenshot-2022-04-27-043506.jpgscreenshot-2022-04-27-043427.jpg


Fence C is short. At first it looked like it was the only one working correctly, showing up following the ground.

But then I got suspicious and turned on wireframe. It too has a straight part buried below ground.


screenshot-2022-04-27-052648.jpg



10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

HybridNZ avatar image
HybridNZ answered HybridNZ edited

Can confirm the following bugs with Vectorplacement.

LOD bug, displays both LOD0 and LOD4
- the 4th LOD is displayed at a different height, this is really amplified when your scenery is at altitude. It sits about 100ft in the air.

Crash to desktop every time you load a vector placement scenery in devmode and try to return to the main menu from dev mode. This is 100% reproducible every time.

Several times we have had it where the XML was corrupted with an incomplete vectorplacement tag, we manually edited the scene XML file to locate and remote the offending element.


10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

Boris_ avatar image
Boris_ answered HybridNZ commented

Hello there,

The lod issue has been fixed for SU10

As for the CTDs, we are investigating

Regards,
Boris

3 comments
10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

Thanks for the reply Boris,


Are we saying that for the LOD issue Vectorplacement tool shouldnt be used until SU10 ?

0 Likes 0 ·

I can't suggest you to use a tool that has some issues ;)
So yes, you will need to wait for SU10 and I'm sorry for this delay,

Regards,
Boris

0 Likes 0 ·
Thanks, We just needed to properly understand the impact and time for repair.


Well take steps now to mitigate the issue which will probably include removing LOD ranges from the XML and delaying the xbox release on the microsoft platform and just releasing on other platforms for PC only.

0 Likes 0 ·
HybridNZ avatar image
HybridNZ answered

For other developers with 3rd party models changing 90 degrees when using vector placement. Make sure you have set the following.

- you have to have Y in blender as forward back axis

and you have to have all transformations and scale set to 0

10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

Boris_ avatar image
Boris_ answered

Hello again,

The CTD has been fixed for SU10 (as well as the LODs issue of the VectorPlacement tool if you didn't see my comment above)

Regards,
Boris

10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

HybridNZ avatar image
HybridNZ answered Boris_ commented

Hi Boris,

The problem we all now have in the scenery design world is a lot of us have been using the new Vector tool for the last 3 or more weeks to great effect.

We are now being told that our scenery isn't going to work properly and cause CTDs and the earliest we can expect our scenery not to affect users or be in a releasable state is SU10 which is end of June ?

- Our options at this point look like we reverse 3 week worth of work (remove all Vector Replacement objects from the scenery) and spend a considerable amount more time replacing objects manually.

- Or halt all releases till SU10

I understand these fixes have a schedule and more importantly a test schedule, but is it all possible to post this as a hotfix ? (Probably a big ask)


1 comment
10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

Hi @HybridNZ ,


You said you worked 3 weeks on it so I guess it was during the beta.
I suggest you to avoid making production product when using tools that are in beta state

However, I can't agree more on the fact that this is exhausting to do all the hard work again, and I understand,

Sorry for the inconvenience caused

Regards,
Boris

1 Like 1 ·
FlyingsCool avatar image
FlyingsCool answered

Do we even understand how we would want it to work in these situations? Are we expecting the shape of the fence to morph with the hill, maintaining vertical supports, with each support at ground level at that point?

10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 5 attachments (including images) can be used with a maximum of 19.1 MiB each and 23.8 MiB total.