plane icon Welcome to Microsoft Flight Simulator’s SDK Q&A Platform!

You have questions regarding the SDK? DevMode Tools? SimConnect? You would like to submit an idea for future improvements, seek help or exchange knowledge? You’re in the right place.

In the upcoming flighting, we've changed the behaviour of the content.xml file. If your addon uses this file, please read this article!

Please take a moment to read the platform’s guidelines before you get started!


question

ftsxfreelw avatar image
ftsxfreelw asked bravoairspace answered

Polygon vegetations do not work anymore.

Hello,

I have version 1.24.5.0 of MSFS with SDK V0.18.0 and since a few days the vegetation polygons do not work anymore. The options to remove and add vegetation are not working. On the previously compiled scenes it is also the same thing, all the work done is not taken into account. I went back to SDK V 0.17.1 and it's the same thing.
I read on this post: https://devsupport.flightsimulator.com/questions/5330/vegetation-slider-doesnt-work-anymore.html
This problem has already been encountered by some people but I didn't get an answer, so I'm posting again to make it more visible.
I deactivated the DevMode and now on scenes using polygon vegetation it works again but when I switch back to DevMode the problem reappears and the use of polygon vegetation options are inoperative.
Do you have, friends designers and community leaders the same problem and if not what to do?
It seems to me that the problem appeared last Thursday, it was working at least on Wednesday.


Regards,

ftsxfreelw





bugsu8
10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

mamudesign avatar image
mamudesign answered ftsxfreelw commented

Can you please make sure that in the Dev menu/ options / terrain has Draw Shapes Active

Without draw shapes, the polygon are not rendered

options-1.png


options-20.png


options-20.png (37.4 KiB)
options-1.png (206.8 KiB)
1 comment
10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

Thank you very much, it was as simple as that ! Problem solved !


Regards,

ftsxfreelw

1 Like 1 ·
Ironpot avatar image
Ironpot answered Boris_ commented

Hi @Boris

No this is not the answer. I can confirm that in SU9 BETA (125.5.0), it is not possible to use the sliders and SEE the affect when changing vegetation, reducing density or size. This is in Polygons. Once built, the vegetation appears but not being able to see it when creating it in DEV mode is difficult. If you re-edit, there appears to be no change until you re-build and re-load the entire project - that is close MSFS and restart.

Additionally, existing polys with vegetation overrides and set sizes now display as overgrown or non-existent depending upon the density selected.

This is using the sliders to add vegetation and nothing is there

1650434004571.png

After build and re-start of MSFS to re-load

1650433970882.png


1650433970882.png (1.5 MiB)
1650434004571.png (1.6 MiB)
1 comment
10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

Hello @Ironpot ,

Yes, that's the correct answer to @ftsxfreelw question. As you can probably see, his problem was solved.


Please create a separate question since your problem is not the same as his.


Regards,
Boris

1 Like 1 ·
bravoairspace avatar image
bravoairspace answered

Hello,

I can create vegetation with polygons on new scenery but not on an older scenery. Just attempted today. My Draw Shape is active. Please let me know how to fix this. Thank you.

10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

Boris_ avatar image
Boris_ answered FlyingRaccoon converted comment to answer

Hello there,

While we investiguate this, as a workaround, you could remove your materialLib asset or you can add an asset type BGL named fs-base (which refers to an empty folder) and then do a Clean build and restart MSFS2020

9 comments
10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

I did a rebuild several hours ago. I was able to control and apply vegetation polygons as normal but the build in the package folder that goes to the community folder had the default vegetation. So, rebuilding helped yet the package didn't build with the custom vegetation. Thank you for checking this out.
0 Likes 0 ·

Unfortunately, the workaround didn't deliver any positive results. All default vegetation is still there. I'll be hoping for a fix as soon as you guys can deliver it. Thank you.

0 Likes 0 ·
Can you send us your project ?

See 3) Provide private content

0 Likes 0 ·
Yes, I'll send them. I must add that when the airport is loaded in the sim, the vegetation works, then go out, start in another airport then leave that one, return to the airport with the vegetation modifications and the default trees are there. It comes and goes. It's like it can't decide or taking turns between the custom and default vegetations.
0 Likes 0 ·
Show more comments
Boris_ avatar image
Boris_ answered
Hello @bravoairspace


I checked your project and there are some errors in your simobjects (animated people and jetway) and in the marketplace data. Check the console for more information about it.
For the vegetation issue, I was not able to reproduce your issue but this may be fixed by the today hotfix.
You can remove the fs-base workaround and let me know if it's better now

By the way, I removed the PackageInt and Package folder since I was having some CTD during the building process. I suggest you to do the same to be sure to have a clean project, just in case ;)

Regards,
Boris

5 comments
10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

Ok. Thank you for checking that out. Normally I don't get CTD except right now when I deleted the [fs-base] folder.

The sim was updated and I still can't create vegetation. I just want to make sure my final package is going to be fine with customers because I would like to upload a small update.


0 Likes 0 ·
Hi @bravoairspace ,

I suggest you to clean your package before making any more tests. You have a lot of files in PackageDefinitions\ and it can cause behaviors like that.
You can use the project wizzard to create a blank and clean project and after that you will be able to add your modelLib / SimObjects etc ..

Regards,
Boris

1 Like 1 ·
Thank you Boris.
0 Likes 0 ·
Show more comments
I have another project where I can summon trees but my old and first airport project it seems corrupted perhaps. I need to make time to check it out. Thank you


0 Likes 0 ·
bravoairspace avatar image
bravoairspace answered

I must add to this thread the fact that the ability to exclude vegetation has return.

Nonetheless upon further testing I found that I'm able to exclude vegetation outside the airport area. Meaning that I can exclude vegetation on about estimated 2000 meters, more or less from the airport. I haven't made time to investigate what command/item/object(s) is preventing me from excluding vegetation, yet it can be done outside the airport area. I use default SDK Dev Mode settings. All standard and basic.

If anyone knows of a setting that prevents the use of vegetation exclusion, please let me know.

Thank you.

10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 5 attachments (including images) can be used with a maximum of 19.1 MiB each and 23.8 MiB total.