plane icon Welcome to Microsoft Flight Simulator’s SDK Q&A Platform!

You have questions regarding the SDK? DevMode Tools? SimConnect? You would like to submit an idea for future improvements, seek help or exchange knowledge? You’re in the right place.

In the upcoming flighting, we've changed the behaviour of the content.xml file. If your addon uses this file, please read this article!

Please take a moment to read the platform’s guidelines before you get started!


question

Flysimware avatar image
Flysimware asked Nocturne commented

Vertex Alpha for ice does not work

I have tried for hours to find out why the vertexpaint using the alpha channel shows ice on the entire mesh for white and black areas. After too many tests i found if i take a old working mesh that had a working ice effect and attach that to a new mesh then delete the old mesh it works. This means adding a vertexpaint to any new mesh will never work. I assume something has changed as my older mesh works. Please advice as i am not confused on how this works. Thanks.

aircraft
10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

Flysimware avatar image
Flysimware answered

UPDATE: I may have finally figure this out. I need to make sure the vertex color is fully white. Then remove this channel. Doing some more testing.

10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

Simbol avatar image
Simbol answered Nocturne commented

@boris,

We users of 3DS have an issue with Vertex paint, which fails to apply the alpha unless you do a trick first with the Vertex pain color channel, this is an issue of 3DS which was mentioned in the SDK before, it seems this reference and warning has been removed from the SDK documentation, and when I click the link where the instructions to bypass this bug were explained, it is going nowhere.

1655126067017.png


The issue remains with 3DS Max, could you guys put the documentation again? I have been trying to figure out with Momo this issue because I did remembered from the documentation, I wanted to give him the steps but we both discovered it was removed from the SDK.

Thanks,
Raul


1655126067017.png (234.9 KiB)
2 comments
10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

@Nocturne can you check this please :)

0 Likes 0 ·
Having revised the situation it seems that this issue is indeed still present and so the "notes on vertex alpha" section has been re-added into the documentation. I was mistaken in thinking that it had been resolved, which is why it was initially removed. Sorry for any inconvenience that this may have caused, and the note will be available again in the SU10 documentation when that update goes live.
1 Like 1 ·
Flysimware avatar image
Flysimware answered Flysimware edited

UPDATE: After testing 3 different tests this is my results.

You can add 2 modifiers a vertex color and vertex alpha and it works. Or add both modifiers convert to poly then just re add the vertex alpha and this will work each time after. But if you just add vertex alpha it will NEVER work.


10 |10000

Up to 5 attachments (including images) can be used with a maximum of 4.8 MiB each and 23.8 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 5 attachments (including images) can be used with a maximum of 19.1 MiB each and 23.8 MiB total.