3DS Max Script error

Hey Guys, I’ve just installed SDK 0.17 and get the error (listed below) after
3ds Max loads. Error is present in Max 2021 and 2022. Max 2019 seems to be
okay. PS. Thanks for the Max 2022 support ---------------------------
FlightSim --------------------------- Error opening msfs_max_py.py: --
Runtime error: Traceback (most recent call last): File “C:\Program
Files\Autodesk\3ds Max 2021\Python37\lib\importlib\init.py”, line 127, in
import_module return _bootstrap._gcd_import(name[level:], package, level) File
“”, line 1006, in _gcd_import File “”, line 983, in _find_and_load File “”,
line 967, in _find_and_load_unlocked File “”, line 677, in _load_unlocked File
“”, line 728, in exec_module File “”, line 219, in _call_with_frames_removed
File “C:\MSFS
SDK\Tools\3dsMax\FlightSimPackage\scripts\msfs_max_py\init.py”, line 36,
in import MultiExporter File “”, line 8, in find ImportError: bad magic
number in ‘MultiExporter’: b’\x03\xf3\r\n’ --------------------------- OK
---------------------------

I’ve got the same, was working fine before update…

Hi, please check this answer…seems to me something is wrong with the
installed tools [SDK 0.17.0.0 Material issues - MSFS DevSupport
(flightsimulator.com)](https://devsupport.flightsimulator.com/questions/5895/sdk-01700-material-
issues.html)

@lpierabella I’ve run through those steps, reinstalled SDK didn’t work,
uninstalled, and reinstalled also no success. ( see screenshots below of my
file structure)

No change, however, there are
more folders in my flightsimpackage/scripts/ : than it shows in yours.

Looks like they also removed a lot of tools. Or maybe a error?

We’ve run into many issues with the new SDK, reverted back to v.16 for now
until it’s fixed.

Hi, I suggest you remove the entire FlightSimPackage folder and re-install the
SDK In your scenario the old tools are living with the new ones… this is the
correct folder structure

Did they fixed the SDK V17? I still have missing maps when opening a previous
project created with SDK 16 plugins.

Hi got this problem with SDK V18 is there any news on this or a trick? Thank’s

Hi, I have a problem myself with V0.18 on Max 22 Windows 10.

Hello @SimbioGT Can you try this please : - close 3dsmax - uninstall the
core sdk 0.17 - check that the sdk core files/folders have been correctly
deleted Only then you can install the core sdk 0.18. After that, it should be
working, Regards, Boris

Yes, leftover was the problem. By the way, why sample can’t be downloaded by
the dev menu only doc and core is possible. Thank you

Glad it worked :wink: As for your other issue, I just tried and everything is
working (it takes like 10-15 seconds to start downloading, maybe that’s why
you think it’s broken) Feel free to create another ‘question’ about this one
please Regards, Boris