Airport showing as water runway when using transparency option for runway material

Hi since the SU10 BETA and SU10 release when setting the runway material to be
transparent using the transparency tick box on the runway options. Some people
are having the airfield show as a water port, I did myself after installing
SU10 before updating it was showing as a land airport just fine. I only had
anyone mention this when SU10 beta’s were out fine before that. I thought I
had fixed it after removing the transparency on the runway material saving the
build then re-applying runway material transparency and saving and building
the project again. It showed as a land airport after that for me, so i
released a new build thinking it was fixed but others are still having the
airfield show as water airfield even though it’s working fine for me. Do this
to use the realistic looking default runway texture already there by default.
Just to add with this glitch airport doesn’t show on world map unless you type
in EGHN in world map search bar. The airport is usable when flying in from
elsewhere in sim, so is loading in fine. So right now, it seems you can’t use
the transparency option when setting runway material as turns airport into a
water port for others. Link to my freeware airport if want to try it to see.
Can provide the project file if needed by dev’s. [Sandown Airport-EGHN-Isle Of
Wight » Microsoft Flight Simulator](https://flightsim.to/file/29821/eghn-isle-
of-wight-sandown-airport)

Hello @DORRAGER , I was not able to reproduce this
behavior. To me, it sounds like a cache issue… Try to delete craigr-eghn-
sandown.dat in this folder

      1. C:\Users\<UserName>\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache\SceneryIndexes\

and then restart the sim. is it better ? Regards, Boris

Hi i can’t currently reproduce the issue myself either since i rebuilt the
project and then put new package folder in my community folder. For me it’s
fixed but others still seeing airport as water port. Should I get those that
have downloaded the add-on and seeing the issue to clear that file you mention
above to? Thanks for the quick reply.

Yes you can tell other users to delete craigr-eghn-sandown.dat and see if it’s
help Other than that, since we can’t reproduce this behavior, I have no other
option at this time Regards, Boris

Thanks, I appreciate you can’t do much if isn’t happening to you. I couldn’t
do anything until issue happened to me either. I have shared this info and
asked for feedback to see if it works. Ill let you know when I hear back.
Thanks again.

Another idea: can you tell them to delete any other scenes in the community
folder (maybe there is a conflict somewhere). I will continue to run some
tests Regards, Boris

I just heard back from the person who reported the issue in the first place.
He says with the latest add-on build it fixed the problem for him. I did
suggest to the original feedback that they could try clearing the community
folder before in case of any conflicts. The new person reporting the problem
with the latest build hasn’t got back to me yet. I’ll ask them to try removing
other files from community folder if that doesn’t work.

I’ve a similar issue with my own scenery (which is a heliport), so we use
transparent runway to enable spawning:
https://flightsim.to/file/37736/bergen-helipads After SU10, it does not
appear in the map. Though you can find the aerodrome by searching for it in
the dropdown menus, though then it warns me about water runways as mentioned
in the issue above as well. I’ve tried rebuilding the scenery, and deleting
the .dat file as suggest as well. Not sure what other things I can test to
make it appear back on the map and not be classified as a water airfield?

Hi did you try removing the transparency saving and building the project with
a texture then switching it back and save and building again this is what
fixed it for me. But it still done the same thing to someone else when I
released that build. I haven’t had any feedback yet to know if the above dev
solution fixed the issue or not in my case.

Thanks. I’ve tried rebuilding as suggested to no avail. Still the same issue.
@Boris1 if you need me to test something as well
with similar issue, let me know. I hope we don’t need to wait until SU11 for a
fix? :confused: I’ve also cleaned absolutely all other sceneries, so conflict is not
the part of the issue here.

I have this issue now on an airport I did some 12 months ago. Users including
myself report:

  • “You cannot take off from a water runway”
  • The airport does NOT show on the world map
  • The airport is kilometers from any water

I have tried rebuilding the package etc. If I load a plane with floats - I’m
placed right in the middle of the airport on dry land… 1.29.25.0 is my
build

Hello guy. We already had a problem like this, the error is due to the lack
of material in the runway, if you are using an apron as a preferred layer you
should still leave a type of material associated with the runway and only then
leave it transparent, if you are only using the runway you just try to update
her material!

Thanks. I’ll give it a go

Ok you can make the material transparent but it boils down to the material you
choose first. I had to make the runway Jima grass first and then I could make
transparent. That fixed the issue.

Just to update I’m not 100% sure but I believe the issue for my airport was
that for Runway configuration id ticked the boxes for no primary landing and
for no primary take-off. Since unticking, so far for this one person unticking
those has fixed it. I only noticed because I realised when talking to ATC my
main runway wasn’t selectable as a runway for take-off. Nobody had mentioned
this to me so had overlooked it.

I am having this issue with the latest Helipad option as a start position. I
do not want the Helipad to have the H sign so I select the type None. But when
I test the installed scenery by selecting the default Bell helicopter and then
select one of the helipads in my scenery, I get the error that the aircraft
cannot start from a water runway.

I confirm that for Runways, we need to add a material and then make it
transparent. Without a material , it will give the water runway takeoff
warning. However, when it comes to Helipads that now can be set as a starting
position, if we select None for the Helipad type and it shows as a transparent
box, we get this error as well. Yet I also noticed that this does not happen
with all helipads with None properties and I am investigating why in some
cases it is producing the water runway issue