AMBIENT TEMPERATURE - Wildy Inaccurate

I hope this is the correct forum for this type of question.

This is part of my code that I am having an issue with.

font_size_1 = “35px”
font_size_2 = “30px”
font_size_3 = “20px”
font_size_4 = “18px”
font_size_5 = “14px”
panel_label_color = “white”
static_label_color = “yellow”
ap_readout_color = “yellow”
halign_1 = “left”
halign_2 = “right”
halign_3 = “center”

mytext_current_ambient_temperature_label = txt_add("TEMP: ", “size:” … font_size_1 … “; color: " … static_label_color … “; halign: " … halign_1 … “;”, 410, 295, 100, 75)
mytext_current_ambient_temperature_value = txt_add(”—”, “size:” … font_size_2 … "; color: " … ap_readout_color … "; halign: " … halign_2 … “;”, 510, 295, 100, 360)

function display_current_ambient_temperature(current_ambient_temperature)

 txt_set(mytext_current_ambient_temperature_value, current_ambient_temperature)
 print("TEMP:" .. current_ambient_temperature)
 end

fs2020_variable_subscribe(“AMBIENT TEMPERATURE”, “Celsius”, display_current_ambient_temperature)

When I run AirManager it displays the celsiustemperate as 173828.1. The current sim temperature is set to 100F. If I change the sim temp to 50 then AirManager displays the temperature as 1597656. A temperature of 0 returns the value of 1740234.

I verified the sim temp using SPAD and AirManager.

I appreciate your help in figuring out what is causing this strange number.

Thanks

Hi:

have you also tried the SimVar Watcher? As it comes with the SDK and is from Asobo itself I find it to be the most reliable way to quickly check variable values from outside:

Greets,
Ben

1 Like