Asobo Blender Exporter not Populating the glTF File

I’m hoping someone can help. I am trying to switch over to the latest Asobo
Blender exporter from the original Blender2MSFS exporter. I have converted all
of my materials but when I try to export, only the *.bin file is being updated
and the glTF file is not getting updated. According to the Blender2MSFS
exporter, I am still able to export just fine (but of course the materials are
all messed up). Anyway, both the *.bin file and the *.gltf files are
processing just fine with the older exporter and the airplane loads with no
issue other than the entire airplane displaying with a light grey. Because I
do not have multiple LOD’s yet, I am not using the multiple LOD exporter but
instead using the option with the stock glTF exporter in the File–>Export
menu. I have attached 2 pictures of my settings. I know that I am missing
something as it is working for others. Thanks.

if you open the console window (Window menu select “Toggle system Console”) in
blender are there any errors? are the dates of the files changing. ie you know
it’s exporting. also in the include ensure you have checked selected, visible

oh and make sure you select
what you want to export. with the A key

Thanks for the response and that is a nifty little trick with the console
window. I have attached the txt file it generated and I am not sure what
“Object of type bpy_prop_array is not JSON serializable” means for me.
Also, there are a lot of “WARNING: More than one shader node tex image used
for a texture. The resulting glTF sampler will behave like the first shader
node tex image.”
errors, but those look more informational. Anyway, if
anyone has any ideas, I would be much appreciated. Thanks . Edit: I forgot to
add that I had tried the other options that you mentioned (I.e., the limit to
and include options) already several times but I can try them again incase I
missed something.

You can have Better support by opening and issue here: Have you tried exporting
with the batch exporter? No matter that you have only One LOD, i use the batch
exporter all the time for single lods and work flawlessy I put all my mesh in
a single collection, give the collection the name of my final glTF, select the
group by collection name and Export from big Burton on the Asobo Exporter ,
never fails! With your option in the screenshot (wich are defaults) you don’t
Need to select all like the former exporter, the exporter Will exporter
everything in the scene (By looking at your log, the msfs exporter never gets
invoked )

I’ve seen that error before, unfortunately it does not tell you much. try
hiding parts of your model and export until you can isolate the part. Also put
an issue on the git hub site. It will get better priority that here. It will
help us trouble shoot this. do you use bone armature animations? - perhaps
start there. The warnings don’t seem to be an issue. edit: are you doing
anything out of the ordinary to get your model to do something “special”
nothing like morphing -

I’m not using the multiple LOD exporter yet because I have literally hundreds
of collections and need to rethink that before I start using it. I need to
either bite the bullet and go through each collection in the exporter to check
them or I just resort my collections to simplify them, or probably a hybrid of
both. I just did not want to think about this part at the moment, but my
troubleshooting is taking much more time than I wanted it to take. I think
that I am going to strip down my export as DA40CGDFQ suggested and if that
does not work, submit the issue per your suggestion and then I’ll break down
and try the multiple LOD option. Thank you for the suggestion and I’ll let
everyone know what worked.

That is a great idea, I’m not sure why I did not think of this myself as I
have used this tactic of removing most of my model just to getting it to work
and adding things in systematically until it breaks again. I guess that I did
not think of it because the export still worked using Blender2MSFS. I’ll give
it a try and see if I can get it to work.

Thanks to you both for the great suggestions! My issue ended up being the
material on my glareshield, even though I did convert it, it was still causing
the export to fail. I changed its material to my standard flat black material,
and it worked perfectly from there. For anyone else that runs into an issue
such as this, remove everything except for one mesh that you know is as bland
as can be, to just get the export into a working state. Once it is working,
keep adding meshes/collections back in until it breaks again, and that last
item will be your problem. I’ve given that advise on countless occasions, but
I guess sometimes one can get so caught up in the moment and an extra set of
eyes can be invaluable. Thanks again

Any chance you can create a small blend file with this issue and submit it to
the github issues - would be much appreciated.

I have added an issue on the ASOBO git site, just as a placeholder for this
problem. Would you be so kind as to provide a blend file that shows this json
serialize error., It would help us a lot. ASOBO
exporter git