Broken custom ILS after SU11

Hello Asobo team, I like your work very much but once again after a
SimUpdate11, some custom ILS of one of our airport (LFBD) are broken. It is
the 4th time in a year and half that it is happening. This time , a new
compilation with last SDK don’t fix the issue so i need to redo from scracth
once again all the ILSs , hoping it is not the custom ILS who can’t work on
this airportsince SU11. Can you please take care of this basic when you are
doing a sim update. Thanks a lot Kind regards

Hello! Do you have a tutorial on how to create a custom ILS, I’ve tried
following some tutorials but it doesn’t work!

Hello @Kem_Pesim Did you notice the issue during
the flighting or it appeared with the final version of SU11. Can you provide
us with the package/project that produces the problem so I can investigate?
I’m not sure to understand how redoing the ILS from scratch would solve the
problem. Regards, Sylvain

Hi @FlyingRaccoon First the issue was reported
by a user. Then i have tested myself and have the same issue. I have verified
all my other aiports with custom ILS and they don’t have any issues. I don’t
know how or why , i just deleted ILS , recompile , then recreated the Custom
ILSs at LFBD how they were before and now it is working. kind regards Kem

PS: i didn’t tested the beta Su11 , only the fianl version

I noticed also waypoints disappearing. Could this be related?

My airports with custom ILS “lost” waypoints on both approach and arrivals
with SU11 too. Still visible in littlenavmap, but not read by planes.
Workaround that works for now is to set deleteAllILS back to ‘false’, remove
the custom ILS and use ILSreference to point to original navdata instead, even
if that means it’s not always aligned perfectly in height.

I don’t know if there’s ever been an update to this issue but after some
customer reports, it appears our custom ILS has also stopped working with
SU11. I’ve then tried the Guide in the forum which also did not help. I did
notice something however. It will only work if I use devmode to teleport to
the problem airport. But if you load in the airport, or arrive … it will not
work. Tuning to the frequency will show the ILS code but there’s no nav bars,
glideslope, etc.

Hello @AgentMir Can you clarify how you are
checking for the presence of your ILS? Is it through the ILS debug display
We had a few reports of custom data not being correctly loaded in JS based
avionics so I’d like to confirm if it’s a data or avionics issue. Regards,

Hi Sylvain, Good question, I had actually checked with both methods. In every
case, it does show up in the ILS Debug mode, showing all the correct
information. It does not however work on the aircraft. The aircraft does show
the correct IDENT code, but nothing else. If you teleport to the airport from
another airport using the SDK, it somehow starts working. Reload the game, and
it will stop working once again if you load directly into the airport.
Strangely this is only happening at one or two of our airports (NZAA). The
rest seem to still work OK

Hello @AgentMir Can you check if your ILS is behaving correctly when you use
the A310? This aircraft uses the SimConnect facilities functions for its
instruments. This would confirm the issue is with the API and not the data
itself. Regards, Sylvain

Hi Sylvain, just tested with the A310 and can confirm the ILS works with that