[BUG] Incorrect AI traffic behavior during takeoff

In the airport I am building with the configuration shown on the screenshot,
the traffic takes off immediately after entering the runway from the two
taxiways ( as shown in red) whereas it should go the route depicted in green.
It worked fine pre SU9-10 if I remember correctly, but since then no matter
how I change the runway taxiway configuration it just doesn’t work. If for
smaller planes it could be, well, ok, for larger planes this behavior is very

did you test this with the default AI or any 3rd party AI?

I am currently flying with FSLTL, so tested with that. It is very difficult to
test with the default offline AI since nothing really flies in this area. I
assume that it doesn’t really matter what AI you use as the addon creates the
AI flight and then hands it over to the sim, am I mistaken here?

could be related to some of the settings within the aircraft.cfg files. Which
airport is it?

UHSS. This happens with all aircraft.

Hello @ZdenniZ Do you have set a “runway” typed TaxiwayPath object along your
runway and linked it to every runway entry TaxiwayPath?

That is required for the AIs to
taxi along the runway. If that’s how your airport is configured, send us the
package and we’ll investigate further. Regards, Sylvain

Hi Sylvain. Yes, I have exactly the configuration you described:

I also tried to remove the
runway taxiway segment between the taxiway entries to make the AI to taxi
towards the start points, to no avail. Effectively the start points are being
ignored. You can use the same package I provided earlier
https://devsupport.flightsimulator.com/t/5344 about the bug with the
performance hit when moving projected meshes and taxiway points (which is
still there on 1.31.22 btw). That package contains my current taxi/runway
layout as well. Thanks! Denis

Im also having this issue, taxiway type runway

Hello @ZdenniZ That’s right, your configuration seems ok. I even tried to
remove the turn pad and widen the runway but it didn’t change anything. The
SimObject debug AI path tool also shows the correct trajectory, but AI just
doesn’t follow it. And your layout is not very different from the default
airport one so I don’t have an explanation at the moment. This will have to be
investigated by the developers in charge of our AI. Regards, Sylvain

Thank you for looking into this, as I said it worked great 2-3 Sim Updates
back, so I hope this will be backlogged and resolved in an observable future.
There are many airports in the world like this where you don’t have taxiways
leading right to the threshold and current behavior is very unrealistic.