Bus connection initialisation for fuel pump circuit in FLT file not working

Hello, I am initialising some bus-to-circuit connections in the apron.flt file
like following:

circuit.70=bus.1:0
circuit.71=bus.1:0

Circuits 70 and 71 are fuel pump circuits, defined as such:

circuit.70 = Type:CIRCUIT_FUEL_PUMP:9#Connections:bus.1#Power:3, 5, 20.0#Name:Fuel_Pump_Left_Outer ; Fuel Pump 5W
circuit.71 = Type:CIRCUIT_FUEL_PUMP:10#Connections:bus.1#Power:3, 5, 20.0#Name:Fuel_Pump_Left_Mid_Fwd ; Fuel Pump 5W

However, when loading in the sim, the connections initialise as closed
(circuit connected to bus). Toggling the connection using the following key
event:

K:2:ELECTRICAL_BUS_TO_CIRCUIT_CONNECTION_TOGGLE

Works appropriately. I am wondering if there is any special logic relating to
fuel pump circuits that override the connection state defined in FLT file.
Thank you,

First thing is you may have code already disabling the bus to circuit as it
should be already connected. So this is the issue. But to enable it from the
FLT file you use this below which you had. Are you using the [Electrical.0]
section?

[Electrical.0]
circuit.70 = bus.1:0
circuit.71 = bus.1:0

Used to set the initial value of the connection between a bus and a circuit.

Syntax: circuit.N = bus.X:B

where N and X are the IDs of the circuit and bus and B is 0 for an opened
connection, and 2 for a closed one. For more information, please see here:
[circuit.N](https://docs.flightsimulator.com/html/Content_Configuration/SimObjects/Aircraft_SimO/system/electrical.htm#circuit).

I do not understand your suggestion. But the documentation is indeed what I
used to make this code. Yes, I have the [Electrical.0] header - I only
provided the relevant lines of the FLT file.

 But to enable it from the FLT file

I want to disable the connection, not enable it.

Hello @hollandFBW After reviewing this issue, it appears that our
documentation was false, the initialisation of the circuit-bus connection
should be made in the system.cfg file. In the .flt you can change the state &
the circuit power setting of a circuit using this syntax :
circuit.id = State(bool), Power (0.00 / 1.00). For the
battery & alternator you can only set internal switch with a boolean, ex :
alternator.1 = True/False. The documentation will be changed. For your issue
you can disable the pump at the start by typing circuit.70=false,1.00
circuit.71=false,1.00 or just by using the
ELECTRICAL_BUS_TO_CIRCUIT_CONNECTION_TOGGLE key event. Best regards, Yohan

Thank you for your answer. While initializing the circuit switch state (what I
assume the circuit.70=false… syntax controls) does work, I specifically
wanted to use bus connections because the circuit switch seems to be
overridden by fuel Triggers. I wish to implement a default mode where a fuel
pump is never active, even when a Trigger could run. So I used bus connections
instead. Would you be able to provide me with the syntax to put in the
systems.cfg file to initialize the bus connection specifically (not the
circuit state) ? Thanks!

Hello @hollandFBW You can set up you connexion in the .cfg like before with
your syntax :

  1. circuit.70 = Type:CIRCUIT_FUEL_PUMP:9#Connections:bus.1#Power:3, 5, 20.0#Name:Fuel_Pump_Left_Outer ; Fuel Pump 5W

And then use the ASOBO_GT_Update template in a .xml to disable the connexion
at the start of the sim with this kind of syntax : True “Your code to disable
the connexion, something like
K:2:ELECTRICAL_BUS_TO_CIRCUIT_CONNECTION_TOGGLE” doc to this template here :
Updates.xml
(flightsimulator.com)

Best regards, Yohan