Constant CTDs in DEV after SU8 when moving apron or taxiway points

I have STEAM version and successfully used SU8 in BETA to continue editing my
airport. Since the “everyone” release to and latest SDK 17 I am
forced to save my scenery after EVERY step I do - placing or moving something.
I get CTDs basically when I move points on an apron or taxiway. They seem to
accumulate in number (the points) and then after so many movements I get a
CTD. I’ve turned off the dump file because I received at least 18 in a couple
of hours editing. Is this known? How many dump files do you want. Basically,
this is not allowing much progression in development. Placing an apron is OK -
moving points is not. Sometimes after restarting, I simply get a CTD without
even getting to the airport.

I will try dev mode in SU8 but in the SU7 I had the similar CTDs as well as
others here and we were told that this is a known issue that the engine team
are investigating. Not related to Dev Mode. However, I am curious to open MSFS
and try Dev Mode in SU8 to see.

MSFS just CTD in Dev Mode when I was only creating a new scenery Package…
Still unstable unfortunately.

I also have exactly the same problem. Impossible to do any serious work after
SDK 0.17. CTD guaranteed. Community empty, uninstalled and reinstalled the
SDK, no difference.

Hello @Boris Have you overlooked this or is it known and fixed?

Could you explain what you did exactly so that we can try to reproduce the
issue internally? Best regards, Eric / Asobo

Just in case you didn’t read that in another thread: the SDK and the DevMode
are unrelated - sim crashes (which may be due to the DevMode itself or other
parts of the sim) will never be fixed by SDK updates. Best regards, Eric /

Hi @Ironpot , We are still investigating, sorry for
the delay. Can you send us a recent Dump file that was generated with the CTD
you had (the link in the other post is expired) ? Thanks, Regards, Boris

Hi Boris, I removed that dump. This is a new issue to that. I’ll send
tomorrow. As described, moving taxi points or apron points or even
manipulating an apron with a material in it like a parking number causes a
CTD. It seems like you move so many points and then a CTD. Occasionally MSFS
will hang and I have to force the crash. Will try and place 2 dumps for you
with a comment. This was NOT happening with the SU8 Beta and SDK16. When SU8
was released and I updated SDK17 the CTDs started on same project. Is STEAM

Hi Ironpot, can you also give us your hardware configuration ? Regards, Xavier

Can you try this ? : <
drivers-crash-with-long-computations-128745489.html> It can help us to know if
it is linked to a GPU crash Thanks, Xavier

I’ve been having similar issues with random CTDs especially when moving aprons
or taxiways. Interestingly I tried switching to DX12 and so far (touch wood)
haven’t seen any CTDs. Obviously it might just be co-incidence.

I’ve provided the guys with dump files. I’m already on Dx12 so it might be
coincidence as you said. Hopefully they do actually find a cause so it can be

Hello Eric, I tried to reproduce every scenario but unfortunately there is not
one I can reproduce. I get a Dev Mode CTDs since SU7 (After not using Dev Mode
for a while). The one reported here was when I used the Simple Scenery from
the Samples and tried to modify the names and add packages etc. Other times if
I am working on a scenery and after moving some polygon or apron points,
changing material or any basic interaction like these. And I also did some
tests using very basic scenery, no complex 3D elements there. Only aprons,
runways and a couple of polygons. I will try again but unfortunately there is
not one repetitive pattern I can reproduce and report. Merci!

For example, I created, once again a scenery from scratch, in scenery Editor,
added a polygon and went to save the shape file, so I navigated to the folder
to save the shape file, then typed the name and hit save… MSFS crashed to

So there is no constant pattern or scenario. It could be any simple
interaction that results in a CTD.

Today I gave it another try. I opened the simple scenery test project and I
was deleting a package and got CTD.

I am wondering how others are able to create, compile and release their
scenery. It is certainly not happening with everyone. I just want to place a
3D helipad platform in a spot and add a couple of polygons and it’s been since
SU7 that I try to do that with no success.

Based on Ironpot’s response, I thought I’d give switching back to Dx11 a go
and found that it seemed happier than when I previously had switched to Dx12.
If you haven’t already, I’d perhaps try switching to Dx12 and then if that’s
happyish try switching back to Dx11 to see if it helps. Might just be one big
co-incidence again but I wonder if switching between Dx11/Dx12 clears out or
regenerates something which is helping to lead to the CTD?

Hi. Changing MSFS to use DX12 has resolved all my CTDs. Testing has shown that
if I revert to DX11 the CTDs resume. So no coincidence there. My advice is to
switch DX12 on to allow you to continue to develop and also apply this
registry setting for your GPU. This appeared to be also part of the solution
long-computations-128745489.html> Asobo are still assisting with the dumps and

I noticed that if I start the project in Airport Design Editor (ADE Alpha
version for MSFS) and then open it in MSFS Dev mode, I can resume work in Dev
Mode without CTDs. I did this for 2 test projects and so far so good. ADE
creates automatically the structure of the project (folders) as we enter the
basic information. And I am using DX11 here. No idea why ADE initial project
values and structure work in Dev Mode whereas the new project initiated in Dev
Mode result in random CTD following basic naming input or polygon edit etc.