Custom biomes issue with SimUpdate 5

Hey there, we are currenty working on our next scenery including custom
biomes. With SimUpdate 5 our biomes wont load anymore while they worked pretty
well with SimUpdate 4. Something seems to be changed with the SU5. When I take
a look at the species.xml the materials seem to be added by GUID instead of
the material name: SU5: SU4: maybe there is now also a problem with
loading the whole vegetation files, i dont know if the files are loaded
correctly due to missing log entries. Is the following code for the assetgoup
still correct?


Copy false PackageSources\vegetation\ vegetation\


I also add my new SU5 biomes and species files maybe there is also a problem
with those files? they are located to PackageSources\vegetation
25-creativemesh-species.xml
30-creativemesh-biomes.xml Kind
regards, Sascha

We still have this problem, any idea what we could do to fix the biome bug?

It appears your xmls do not have the correct header information I’m not sure
if this is due to uploading to this site but it does look like the xmls are
incomplete. I’m currently working on my work flow, step by step, to try and
find any notable reasons for the problems but without Microsoft to jump in and
actually help then we’re on our own. All I got is being pointed to this forum.
I have to say I give 0 points for Microsoft and Asobo with their lack of
support for devs, they’re the ones who want this product to succeed so they
should be stepping in here to offer some sort of support. Then they get the
credit for all the work devs do to create awesome Addons which they had
nothing to do with. It’s very frustrating as you could understand. If I find
anything I’ll be sure to post back here.

Hey Blackjack, I’m having the same issue with my scenery and it does point to
the biomes file. I have tried everything in my years of knowledge but there
seems to be an issue in the scenery pipeline. I initially thought that it was
to do with the shapefiles or package layout but as soon as I modified the
biomes file my gpu went to 100% and the scenery would load to infinity. I
can’t find any useful documentation on the required workflow that Asobo use
but mine had been working prior to SU5. Let’s hope we get an answer from
someone.

So the issue for me was indeed the material tag causing msfs not to load if it
uses the original names and not the serialized name. So the materials are now
serialized probably due to the inclusion of xbox.

Hello, As you correctly noticed, these textures now must be referred to with
their GUID (which can be found in the Material Editor > File > Copy GUID). The
SDK documentation about that will very soon be updated. Have a good day,

Hi SpritelyNZ, thats why i used the GUID in the Materials line inside the
species.xml: (vegetation_scrub) still wont work for my project msfs is still
loading endless…