Default_bank_mode = 0 broken

I am only enabling the ap master and using the correct cfg settings and the
bank keeps holding the current heading. What is wrong?

      1. default_pitch_mode = 0
  2. default_bank_mode = 0
  3. use_no_default_bank = 1
  4. use_no_default_pitch = 1

or

      1. default_pitch_mode = 0
  2. default_bank_mode = 0
  3. use_no_default_bank = 1
  4. use_no_default_pitch = 1

This is similar to my issue with pitch mode not settable.

I will pm you on our Discord.

Hello @Flysimware Are you seeing the correct
simvar values but incorrect behaviour or simvars are not correct either? What
avionics are you using? This is important as avionics can have some
conflicting actions. Regards, Sylvain

I forgot to mention the default C152 does the same as it also uses these same
cfg values. And the 747 too. So this odd if this is not something you do not
see on your end. Please confirm on those aircraft. Simvar is not showing any
bank modes enabled so good there. For avionics I am using the
TOGGLE_AVIONICS_MASTER event.

Hello @Flysimware Default C152? It does not have
an AP as far as I know. So do you mean “default C152” that you have edited to
enable the AP and set default modes? On the 747, the default bank mode is set
to NONE and therefore the bank hold is disabled but enabling the AP will
activate the Heading hold mode that uses the same PIDs. (you can see this in
the Debug->Aircraft->AP devmode window) I’m not sure to understand, what modes
do you want to be active when setting the master AP on in your aircraft?
Regards, Sylvain

I found an easier bird to test. If I load the Pipistrel Virus SW121 then
enable the AP master only this sets to enable pitch and not to enable bank
with NO modes selected as seen in the cfg settings below.

default_pitch_mode = 1
default_bank_mode = 0
use_no_default_bank = 1
use_no_default_pitch = 1

The problem is the ability to bank the aircraft with your stick no longer
works as if there is some type of default bank enabled when we clearly state
none. Also no variable is showing for bank. So is this a bug or conflict or
controller issue on my end? Can you confirm this. I figure this is a bug as I
have all AP controls disabled in my profile and using the button on the panel.
When you enable the AP master and use

default_bank_mode = 0

the stick should be free to bank until you enable HDG or NAV or BC or bank
mode. Basically why is bank holding?

Hello @Flysimware Ok, the SW121 is a good
example. You are right, roll PID seems to be evaluated despite no roll AP
modes being active. I will forward this case to core sim developers and this
will be reviewed. There is no workaround in the meantime I’m afraid. Regards,
Sylvain

@FlyingRaccoon Was this ever fixed? I am about to release a beta of my jet and we need both default_bank_mode and default_pitch_mode to work for mode zero. Seems to still hold with these settings.

default_bank_mode = 0
default_pitch_mode = 0

Please get this fixed for Su13…

1 Like

Hello @Flysimware

Unfortunately, this has not been prioritized yet and is still in our backlog.
This will not be addressed with SU13.

Regards,
Sylvain

You might notice that Asobo is still adverting for an MSFS AP developer.and has been doing so for over a year now

https://jobs.eu.lever.co/asobostudio/cf24e094-1c79-4468-879a-41106f4f51a9

After the release of Microsoft Flight Simulator in August 2020, Asobo continues to work on improving its content. For this, we are looking for an Autopilot Developer M/F who is motivated and eager to produce quality --------

1 Like

I found out our autopilot actually still uses pitch hold and bank hold when all other modes are off. So now this bug is not an issue. Of course it will be nice to get fixed. It actually use to work back in SU9. So not sure if it’s just a limitation now or lack of a coder. Looking forward to more progress. Thanks.

Hi @Asobo, @FlyingRaccoon

Looks like the cfg settings got fixed for modes. Thanks again.

Hello @Flysimware

I’m not aware of any change in that regard.
Pipistrel seems to still hold 0° bank with default_bank_mode set to 0.

What change did you notice exactly?

Regards,
Sylvain

Read your reply on March 17 as you confirmed there was an issue prior to it now being fixed.

Basically these cfg values set to zero would still hold pitch and roll when the ap was engaged and no other pitch or roll modes were active.
default_bank_mode = 0
default_pitch_mode = 0

The funny thing was I found out the project I am working on actually requires these to be enabled. But still good to see it was fixed and I tested zero the other day.
default_bank_mode = 3
default_pitch_mode = 1