Engine Simvar N1 Shutdown Performance - Allow the ability to control Simvar N1 from Idle to Off during Shutdown

Following discussions on Discord, as recommended, I am creating a post here
for the record. Currently, when the engine is at Idle N1 and you request the
engine shutdown, the Simvar N1 behaviour from Idle to Off is hard coded and
far too fast. There is no way we can manipulate this behaviour. Since our
aircraft (PMDG 737) engine sounds are linked to Simvar N1, during shutdown,
all the engine sounds fade away far too quickly. This is particularly
noticeable in the outside views. In SU9 you fixed this same issue for the Off

Idle startup sequence, and we successfully fixed the startup N1 performance
for our aircraft. It works great. Please can you make the same type of fix to
the shutdown sequence, so we can manipulate the time it takes for Simvar N1 to
be much longer in duration from Idle to Off. Thank you, Armen

The approach our engine model developer took to dealing with incorrect primary
engine parameter values during startup/shutdown was to create a set of LVars
(for each engine’s N1, N2, etc) which are used by indicating systems, sounds,
animations, etc. During engine running they simply mirror the sim’s N1/N2
simvars, but during startup and shutdown (which is determined using a state
machine) these LVars are programmed to replicate accurate behavior and ignore
incorrect simulator logic. Hope this helps.

Thank you Iceman for the information. However, how does this work practically?
So we trigger an engine state of “Shutdown” - then what configuration file
will control the alternate N1 shutdown behaviour during the shutdown phase?

Our function
(triggered when an engine master switch is set to off) will set our alternate
n1/n2/egt variables to the right values based on a polynomial regression
that works as a function of time and value during previous timestep. This
could also be done with a lookup table as well. Although it would be nice to
have a native solution in engines.cfg for all this

Thanks again Iceman for the info. Not sure which MSFS update it was - but the
shutdown N1 behaviour changed for the better! I noticed on engine shutdown,
the sounds were playing much longer than previous builds before fading out.
Then I tweaked the 0.5 - 1.0 N1 range for the engine sound layers to increase
the volume in this zone, and now the sounds play considerably longer after
engine shutdown. Very happy with this unexpected change! Thanks to those who
made this improvement!