Exclude (OSM,Floaty etc) Lights

We need to ability, through exclusion rectangles or polys to remove the
default OSM floating street lights. As well we should have the tools within
the light row object to recreate light trails easily maybe with predefined
light presets.

This should expanded more generally with the ability to exclude any kind of
vector data, not just lights.

Lights exclusion feature is available with the SimUpdate 7 update. Feel free
to report your feedback on this new feature!

It doesn’t work.

Check the
image. Both red orb and white orb remains despite of an exlusion poly,
exluding both roads and lights.

@Darwikey FYI

Hi guys, this still isnt working for floating lights. It does work for power
poles/pylons however. cheers Josh NZA Simulations

Hi @HybridNZ To exclude roads and floating lights,
the polygon must include one extremity of the road You can activate the debug
road to help you (Options → Terrain → Debug Osm roads) For example :

There seems to be two types of floating orb lights. This works for
streetlights, not for lights that hover over car parks and other areas. See
these two screenshots and note the problem lights that aren’t going away
around ENLK. (Ignore the purple floating airport buildings) Without exclude,
for comparison:

With exclude:
Streetlights are removed
correctly, but not those other lights.

Tested again with a large exclusion polygon over the city and an airport we
are working on. Definitely only kills the road lights which when you’re making
an airport road lights arent really the issue. The parks and ‘Other’ lights
are. So I would say this item is still very much open and not closed guys. See
below


I agree. It seems like there are different “auto-generated floaty lights” with
a different charactor other than the road- and street lights. This is both
white and red lights - and these cannot be excluded in any way.

Hi Valrok, After some investigations I have found that in your screen, the
white orbs come from an industrial site, and the big red orb from a com mast.
I will make sure the option “excude street light” also remove these white
orbs. And I will add an option (maybe called “exclude feature point”) to
exclude the red light. Regards, Xavier

Ok fixed on my side, it should be available in the next SimUpdate

You’re a legend. Thank you for fixing it. Standing by.

This is still an issue. Neither exclusion rectangles or polygons with
exclusion of streetlights and roads remove the lights as per today, 220130. I
guess we have to wait till the end of February for a possible fix.

I think (from initial testing) since SU8 this now works properly. Exclusion
polygons are actually now excluding all floaty lights.