Exe.xml fails to launch my SimConnect external application

Hi, I’m trying to get MSFS to automatically launch an external SimConnect
application (.exe) whenever the game is launched by placing an entry in the
exe.xml file (at
). My exe.xml file looks like this:

    Auto launch external applications on MSFS start
        My Company MSFS Utilities EXE
        C:\MSFS Online Content\Community\my-company-msfs-utilities\utilities\EXE_Application.exe

However, I’ve had mixed success. The launch seems to randomly fail at times.
It only launches successfully about half of the time. I’ve enabled SimConnect
logging (using the SimConnect.ini file) and the following error is logged
whenever the launch fails:

Exe Launch Failed:  GetLastError=0xC0EA0001  Path="C:\MSFS Online Content\Community\my-company-msfs-utilities\utilities\EXE_Application.exe"  CommandLine=""

Does anyone have an idea what could be causing this seemingly random launch
failure? I couldn’t find details on this error code anywhere. Any help would
be appreciated. Kind regards, Omar

This happened to me as well today and, checking your error code, it means
ERROR_NO_APPLICABLE_APP_LICENSES_FOUND, so it has something to do having an
issue with the MSFS license. I enabled Simconnect logging, and as soon as MSFS
started, it displayed a Simconnect error message, also saying “no applicable
license found”. I think this happened because I moved to my vacation home,
which uses a completely different kind of internet connection and on a
different country too, (Starlink satellite, in Italy, instead of Cable I have
at home in Switzerland), and this must have freaked out the MSFS licensing
system for some reason. It was weird, because the sim itself worked
perfectly fine, showing logged to my normal MS Store account, so I didn’t
realized something was wrong, until I noticed apps couldn’t start from the
EXE.XML anymore. They could be started manually, and they did connect with the
sim using Simconnect just fine. It seems that for some reason, when something
is “wrong” with the license ( not entirely wrong, otherwise the sim wouldn’t
even start ), you lose the ability to start .EXE automatically from the
EXE.XML. I fixed it by logging out of the account from MSFS, then logging in

It seems I spoke too soon: on a subsequent session, I still got the same error
as before, see the attached screenshot:
As before, the rest of the
simulator seems to work normally, just apps don’t start anymore from the
EXE.XML file.

Hello @AS_Omar and @virtuali That’s an issue we’re already tracking. It’s
related to MS Store checking the app (MSFS) has a correct licence but also
checking for child apps and failing in this cas. We will come back to you when
we know more about this. Regards, Sylvain

@AS_Omar and @virtuali Could you tell us which version of Windows and of the
MS Store you have when you experience this problem. We are unable to reproduce
this behaviour at the moment. Regards, Sylvain

Hi Sylvain, I was able to reproduce the same error today (Exe Launch Failed:
GetLastError=0xC0EA0001). My Windows version is:

Edition    Windows 11 Pro
Version    21H2
Installiert am    ‎04-‎Sep-‎21
Betriebssystembuild    22000.652
Leistung    Windows Feature Experience Pack 1000.22000.652.0

and my Microsoft Store version is 22205.1401.13.0 Best regards

I’m using Windows 10, and the MS Store app version is 22205.1401.13.0 The
simulator itself works normally, with all features, so it seems to not have
any licensing issues. It’s just the automatic startup of .EXEs from the
EXE.XML file which is affected, the same apps works normally and connect to
Simconnect normally when started manually. Enabling Simconnect diagnostic log
it’s enough to trigger the problem, and I get the same error code as @AS_Omar
, 0xC0EA0001 , which seems to mean ERROR_NO_APPLICABLE_APP_LICENSES_FOUND

I’m bumping this to report the problem is still happening on the latest build
released today. I’'ve enabled Simconnect logging, and I’ve noticed the first
time the sim is started, I don’t get the error from the Windows MessageBox,
but the same error code 0xC0EA0001 is logged in the Simconnect console, saying
the child .EXE failed to start because of it. Existing and restarting the sim
a 2nd time, instead, result in the MessageBox with the error, but no
Simconnect console opened, as if even the console itself failed to get a
license to start. One thing might be useful to note, is that I have two
separate copies of MSFS with two separate license, one from the MS Store ,
which is the current SU10 Beta, and another one on Steam, which is the latest
official version from SU9. A strange quirk of this configuration is that, if I
start the Steam version, exit from it, and restart the MS Store version after,
it says I’m “logged on another device”, so it suggests to force a logoff from
the other “device”, as if the Steam version was seen as a different device,
because both will login with the same MS Account. Perhaps this might help you
finding the problem, which might be specific to my dual installation ?

From what I can see, this problem has been fixed in SU11 Beta, would be nice
to add it to the Release Notes.

1 Like