Fuel selector inop

Hello, Whatever i tried using this template it don’t select correct fuel tank
or cut fuel when off : False FUEL_Knob_Selector FUEL_Knob_Selector
FUEL_Knob_Selector FUEL_Knob_Selector True OFF LEFT BOTH RIGHT If i try to
change LEFT ; RIGHT tags in LEFTMAIN / RIGHTMAIN , the animation don’t work
anymore I have 4 keyframes in Blender : 0 (off) 1 (Leftmain) 2 (both) 3 (right
main) -So with this tag, the lever animation work but , off position don’t cut
the fuel -Also , if i change False to True , default position of the lever is
wrong -Then when i test to Set : LEFT to OFF insted off LEFT to test , the
result is that the keyframe is ingored Thanks for the help on it Kind regards

You have not setup this correctly. Read this to ensure you have this setup
correctly:
1. Make sure to have 0-3 keys so you have 4 positions. Do not
create a 5th position that cycles to the off position from the right position.
You can only go left and right. So basically no loop. 2. Remove True this is
for the Airbus and Boeing system where they require a pump logic. 3. You can
remove this too. False By default this is true. True will call to
ASOBO_GT_Update_EnsureVariableConsistency_MultiStates and this means: ‘This
template is used to ensure switches that have multiple state have the right
state if their Simvar is changed.’ 4. Include the Knob so it knows what type
of lever. Very important: 5. Use ALL ALL and not both. Because the sim
assignments does not have an option for BOTH (Asobo needs to add this). So if
you only have 2 tanks ALL will work to ensure users with hardware can also
change the selector to all positions. So this code below will work for
hardware and mouse control.

                 Knob
                 FUEL_Knob_Selector
                 FUEL_Knob_Selector
                 FUEL_Knob_Selector
                 FUEL_Knob_Selector
                 OFF
                 LEFT
                 ALL
                 RIGHT

Your config file should look be similar to this when your done setting the AE.
Minus the position and some other settings.

number_of_tank_selectors = 1


[FUEL]
LeftMain = 3,0,1,5,-8 ; For each tank: Tank position (z longitudinal, x lateral, y vertical) (FEET), total fuel capacity (GALLONS), unusable fuel capacity (GALLONS)
RightMain = 3,0,1,5,8
Center1 = 3,0,1,0,0
Center2 = 0,0,0,0,0
Center3 = 0,0,0,0,0
LeftAux = 0,0,0,0,0
LeftTip = 0,0,0,0,0
RightAux = 0,0,0,0,0
RightTip = 0,0,0,0,0
External1 = 0,0,0,0,0
External2 = 0,0,0,0,0
fuel_type = 1 ; 1 = OCTANE 100, 2 = JET_A, 3 = OCTANE 80, 4 = AUTO GAS, 5 = JET B
number_of_tank_selectors = 1 ; Max 4
electric_pump = 0
engine_driven_pump = 1
manual_transfer_pump = 0
manual_pump = 0
anemometer_pump = 0
fuel_dump_rate = 0.02

Hello, Thanks for the answer, I did exactly the same but it seems that the
last update is bugged. I have many issues since.