[FUEL_SYSTEM] still thinks that B747 default system is being used (B777 modification)

m773_305_interior.xml Hello, I
make a modification for B777 by CS with Fuel System and Flight Model
modification. After SU9 update however the current fuel system cause a CTD,
which doesn’t in SU8. Now I’m trying to cut all unnecessary fuel tanks, fuel
pumps, fuel valves, junctions and lines to rewire them together. I’ve also
updated system.cfg and …interior.xml to match my changes. Do I miss
something else? My goal is to get the aircraft in long-term completely
independent from default B747 In dev mode console log I can see “Attempting to
access pump with an invalid ID …” errors, which shouldn’t be there since I
have removed all of those fuel pumps and valves Does any one have an idea what
I’m missing? Thanks in advance :slight_smile:

[FuelSystem]Attempting to access valve with an invalid ID : (Is 24, should be 1 to 9)
[FuelSystem]Attempting to access valve with an invalid ID : (Is 25, should be 1 to 9)
[FuelSystem]Attempting to access tank with an invalid ID : (Is 8, should be 1 to 3)
[FuelSystem]Attempting to access tank with an invalid ID : (Is 4, should be 1 to 3)
[FuelSystem]Attempting to access tank with an invalid ID : (Is 5, should be 1 to 3)
[FuelSystem]Attempting to access tank with an invalid ID : (Is 6, should be 1 to 3)
[FuelSystem]Attempting to access tank with an invalid ID : (Is 7, should be 1 to 3)
[FuelSystem]Attempting to access pump with an invalid ID : (Is 10, should be 1 to 9)
[FuelSystem]Attempting to access pump with an invalid ID : (Is 11, should be 1 to 9)
[FuelSystem]Attempting to access pump with an invalid ID : (Is 12, should be 1 to 9)
[FuelSystem]Attempting to access pump with an invalid ID : (Is 15, should be 1 to 9)
[FuelSystem]Attempting to access pump with an invalid ID : (Is 16, should be 1 to 9)

Edit: Interior buttons can be fixed by renaming the included WASM module. That
error message mentioned above still exitsts

Hello. “In dev mode console log I can see “Attempting to access pump with an
invalid ID …” errors, which shouldn’t be there since I have removed all of
those fuel pumps and valves”
These errors are showing because you’re calling
valve events on valve that no longer exist. Your xml file seems to still
reference the valve you’ve deleted from the system.cfg. Regarding the CTD you
get. I can help diagnose what’s causing it if you provide us with a full dump
file. [http://devsupport.flightsimulator.com/t/how-to-report-a-bug-or-
crash/77](https://devsupport.flightsimulator.com/t/how-to-report-a-bug-or-
crash/77) Regards, Sylvain

Thanks for your fast reply. I still cannot find that pumps or valves
definition in the _interior.xml or any other xml, but at least after that
unsued fuel pumps and valves are cut off I have no CTD. I will send you over
the full dump of the previous version, which worked on SU8

In the xml you provided, for example:
This will trigger an error as
the subtemplate will send events on valve that no longer exist. Regards,
Sylvain