FuelSystem: Problems with Junctions in Su9

Dear Asobo developers. As much as I try to understand what you have done with
the Fuel system from SU8 to SU9, it is clear that something is wrong with the
junctions since then. I don’t know what you understand by junctions, but what
I understand by junctions is the union of two or several lines, which, if
open, should allow the flow of fuel to pass without offering any resistance,
at least it worked like this until now. The most obvious problem is that if I
have two junctions joined by a line, I don’t care which direction the fuel
goes, there is a clear resistance to the passage of it that there wasn’t
before. I haven’t put options on these joints because it was not necessary,
the fuel passed freely according to the pressure of the tank pumps or if the
valves were open or closed, but now it is something impossible. A example will
be: - Tank1 - Tank2 - Tank1Pump - Tank2Pump - JuncA - JuncB - JuncC -
JuncD - Valve1 - Valve2 - Valve3 - Valve4 - Valve5 - Valve6 - Valve7 -
Tank1 to Tank1Pump - Tank1Pump To JuncA - JuncA to Valve1 - Valve1 to Tank1
- JuncA to JuncB - JuncB to JuncC - JuncC to Valve2 - Valve2 to Tank2 -
Tank2 to Tank2Pump - Tank2Pump to JuncD - JuncD to JuncC - JuncD to Valve7
- JuncB to Valve3 - JuncB to Valve4 - JuncC to Valve5 - JuncC to Valve6
Assuming I want to get fuel from tank2 to tank1, I simply close tankpump1 and
all valves except valve1, and fuel flows from tank2 through the tankpump2 and
through the junctions. And vice versa, when it comes from tank1 to tank2,
pump2 closed, valve2 open and the rest of valves closed. When this worked
great in SU8, in SU9 it is unfeasible, since Fuel rate is reduced as it passes
through each junction. Each junction opposes a resistance that did not exist
before, and fuel is not escaping everywhere since the rest of the valves are
closed as I said. Using these parameters #FuelFlowAt1PSI:0.1#Volume:0.24,
which are the default values and the pumps go to 45 psi, which should be
enough to move fuel is not working in SU9, while in SU8 worked reall great. If
there are no junctions, there is no problem. But it is not a solution since
those junctions are necessary to move fuel to other tanks or even engines
through check valves open or closed. in some of these lines I am being forced
to add parameters like #FuelFlowAt1PSI:20#Volume:0.24 (changing volume has no
effect), but it is impossible to make the fuel flow equally in both directions
at the same rate. It is evident that you have changed something and that you
have not documented, or you are not aware of what you have done and you have a
bug. But I hope you solve it or give us some information.

Hello @CodenameJack447 Just to make sure I understand. You diagnosed this
issue by watching the FUELSYSTEM_LINE_FUEL_PRESSURE simvars in SU9 and seeing
a difference between the configuration with and without junctions, am I right?
If the junctions are behaving this way, this is definitely not on purpose and
I’ll investigate. If you can provide me with the FUELSYSTEM section you made
your tests with to make sure we’re in the same conditions, that would be
helpful. Thanks Regards, Sylvain

Hi, yes is Concorde related, so the best example is you check it if you have
access as I suppose you have access to it because it is in the marketplace. In
SU8 the fuel transfer worked correctly, in SU9 it stopped working in two
aspects, transfer of tanks 9, 10 and 11 between them, as well as directly to
the engines since there are many junctions along the way. Also, I am designing
the fuel system of the f-15, and although it is smaller I am facing the same
issues when the fuel has to go through joints. I think the best thing to do is
to check it out for yourselves. since you have a plane in which you can
manipulate switches.

What I mean is that basically I had to increase fuel flow through the joints
for fuel to travel, but this had not been done before, the transfers traveled
perfectly in SU8. An example between junctions would be: Line.150 =
Name:TT9LJuncToTT10LJunc#Source:TT9LJunc#Destination:TT10LJunc#FuelFlowAt1PSI:20#Volume:0.24
Line.151 =
Name:TT10LJuncToTT05SIVJunc#Source:TT10LJunc#Destination:TT05SIVJunc#FuelFlowAt1PSI:20#Volume:0.24
Line.152 =
Name:TT05SIVJuncToTT05IVJunc#Source:TT05SIVJunc#Destination:TT05IVJunc#FuelFlowAt1PSI:20#Volume:0.24
Line.153 =
Name:TT05IVJuncToTT06SIVJunc#Source:TT05IVJunc#Destination:TT06SIVJunc#FuelFlowAt1PSI:20#Volume:0.24
Line.154 =
Name:TT06SIVJuncToTT11LIVJunc#Source:TT06SIVJunc#Destination:TT11LIVJunc#FuelFlowAt1PSI:20#Volume:0.24
Line.155 =
Name:TT11LIVJuncToTT11LHYDJunc#Source:TT11LIVJunc#Destination:TT11LHYDJunc#FuelFlowAt1PSI:20#Volume:0.24
Line.156 =
Name:TT11LHYDJuncToTT11LJunc#Source:TT11LHYDJunc#Destination:TT11LJunc#FuelFlowAt1PSI:20#Volume:0.24
Line.157 =
Name:TT11LJuncToMJVLeft#Source:TT11LJunc#Destination:MJVLeft#FuelFlowAt1PSI:0.01#Volume:0.24
Line.158 =
Name:TT9RJuncToTT10RJunc#Source:TT9RJunc#Destination:TT10RJunc#FuelFlowAt1PSI:20#Volume:0.24
Line.159 =
Name:TT10RJuncToTT07SIVJunc#Source:TT10RJunc#Destination:TT07SIVJunc#FuelFlowAt1PSI:20#Volume:0.24
Line.160 =
Name:TT07SIVJuncToTT07IVJunc#Source:TT07SIVJunc#Destination:TT07IVJunc#FuelFlowAt1PSI:20#Volume:0.24
Line.161 =
Name:TT07IVJuncToTT10SIVJunc#Source:TT07IVJunc#Destination:TT10SIVJunc#FuelFlowAt1PSI:20#Volume:0.24
Line.162 =
Name:TT10SIVJuncToTT08SIVJunc#Source:TT10SIVJunc#Destination:TT08SIVJunc#FuelFlowAt1PSI:20#Volume:0.24
Line.163 =
Name:TT08SIVJuncToTT11RIVJunc#Source:TT08SIVJunc#Destination:TT11RIVJunc#FuelFlowAt1PSI:20#Volume:0.24
Line.164 =
Name:TT11RIVJuncToTT11RHYDJunc#Source:TT11RIVJunc#Destination:TT11RHYDJunc#FuelFlowAt1PSI:20#Volume:0.24
Line.165 =
Name:TT11RHYDJuncToTT11RJunc#Source:TT11RHYDJunc#Destination:TT11RJunc#FuelFlowAt1PSI:20#Volume:0.24
Line.166 =
Name:TT11RJuncToMJVRight#Source:TT11RJunc#Destination:MJVRight#FuelFlowAt1PSI:0.01#Volume:0.24
However, now to control the fuel that enter the tanks from this junctions
would be: Line.124 =
Name:TT05SIVJuncToSIValve05#Source:TT05SIVJunc#Destination:SIValve05#FuelFlowAt1PSI:0.01#Volume:0.24
Line.125 =
Name:TT06SIVJuncToSIValve06#Source:TT06SIVJunc#Destination:SIValve06#FuelFlowAt1PSI:0.01#Volume:0.24
Line.126 =
Name:TT07SIVJuncToSIValve07#Source:TT07SIVJunc#Destination:SIValve07#FuelFlowAt1PSI:0.01#Volume:0.24
Line.127 =
Name:TT08SIVJuncToSIValve08#Source:TT08SIVJunc#Destination:SIValve08#FuelFlowAt1PSI:0.01#Volume:0.24
Line.128 =
Name:TT05IVJuncToIValve05#Source:TT05IVJunc#Destination:IValve05#FuelFlowAt1PSI:0.01#Volume:0.24
Line.129 =
Name:TT07IVJuncToIValve07#Source:TT07IVJunc#Destination:IValve07#FuelFlowAt1PSI:0.01#Volume:0.24
As you can see between joints I am forced now to use 20PSI for fuel to travel,
but when I reach a valve I have to lower the psi to 0.01 (because then I empty
the tanks in seconds). This didn’t happen before, I didn’t even have to add
anything. #FuelFlowAt1PSI:0.1#Volume:0.24 is the default value according SDK,
but in unions it no longer works and I am forced to add them with ridiculous
values.

Please let me know how the out come is. I still have issue with APU wiring for
my B777/B767 mod. It only works when I turn FWD LEFT PUMP on (it should get
fuel from Left Tank on the same Fuel Line like where that pump is connected)

Hello @CodenameJack447 My apologies for not coming back to you earlier. Thanks
to your feedback, we have been able to reproduce the problem you’ve mentioned.
It occurs when one of the output lines of a junction is closed (if it leads to
a closed valve for example) and will cause a drastic drop in fuel flow. We
have a fix for this but haven’t made a decision yet on how we will handle this
to avoid causing any regressions on existing products. I’ll come back to you
when I have more information but I’d say if you don’t plan to release the
product you’re working on before SU10, it’s probably not worth trying to work
around the issues you have with this on SU9. Regards, Sylvain

ok, I stay at peace then knowing that the problem is real and not mine. I
managed to finish the actual fuel system for the F-15, and although it works,
I had to do tricks to get the flowing fuel to its destination, although there
are curiously lines between junctions where I measured not flowing fuel at
all, but Interestingly there are fuel flow in the next line. I guess if you
end up fixing it I won’t have to make many changes later. We have no choice
but to wait since you have a more serious problem now and that is that we
cannot compile projects since last patch, which has stopped production for
many of us unfortunately. I will only tell you one thing and I do not expect
an answer, only that you reflect among yourselves: you must regain control of
the situation, it is not normal that after each update aspects that worked
perfectly, now are damaged, but also that you are not aware of it. Aspects
that has nothing to do with what you are supposed to fix. This is without a
doubt the update that has caused the most collateral and direct damage to
everyone in general, to a point where the players do not enjoy it and neither
do we. You seem to schedule update releases without any apparent quality
control over them and people have a limit. It takes a lot to lift something
from scratch and only a few seconds to destroy it if you’re not careful about
what you do. Thanks.

Hey @FlyingRacoon, Good to hear that there is a fix coming, but I’m curious
about your comment: “We have a fix for this but haven’t made a decision yet on
how we will handle this to avoid causing any regressions on existing
products.” Unfortunately we are hit constantly with regression issues with
every sim update, where something that worked previously no longer does. So
why is that all of a sudden a concern now. Sorry for the salt, but if
something is wrong, it should be fixed, documented and your “partners” alerted
of the change.

Specially considering that QA has been a problem since day one! And as of this
message we are at day one + 639…

That’s what I meant in this comment. My apologies if this is not clear. We
identified the problem, have a fix for it, will deploy it in a way that causes
no regression, and will communicate on what to change if you want to use the
fixed version.

Don’t worry about regression LOL. Better documentation and communication
ensures we can ALL fix the issues and ensure cleaner code on your end.

Hello everyone Some more info on this issue. With SU10, the issue with fuel
flow dropping when junctions output lines are closed will be fixed. We have
added a fuel system version number in the cfg to let people decide if they
want to stay on SU8, SU9 version or use SU10/Latest version. Please come back
to us on this platform if you encounter any issue when SU10 flighting starts.
Regards, Sylvain

Hi, I would like to raise this issue regarding fuel flow through junctions
once again. I am experiencing a slightly different issue where the fuel flow
through multiple junctions is dropping with no opening or closing of junction
output lines or valves. In this system, there are lines from two pumps feeding
a junction with multiple output lines. Only output line has throughflow and it
leads to another junction. There is also only one output line in operation in
this junction, which leads through a valve to a fuel tank. At the first
junction (where the flow from the two separate lines with fuel pumps (each
putting out the same pressure) is combined, the flow rate is, as expected,
twice the flow rate of each input line. However, the flow rate from this
junction through the only output line in use (going to the valve before the
destination fuel tank), is half the flow rate of the first junction, although
it will jump between this value and the full flow rate of the first junction.
And then the flow through the valve to the destination fuel tank jumps around
from values between 1/4 of the input flow for the first junction up to the
full value of the input flow at the first junction. (This is all with the
default fuel line parameter values of fuel flow at 1PSI and volume.) Another
thing I noticed is that for the options setting, all input lines are always
open with no need to specify them in the specific options. I assume this was
intended, but it is not mentioned in the SDK. Something to add perhaps?

Hello @donstim Can you please create a dedicated question as well as provide
your flight_model.cfg file so we can check this? Regards, Sylvain

Done.https://devsupport.flightsimulator.com/t/5361