Handling LODS in new Asobo Blender to MSFS multi exporter Exporter

I am having some difficulties exporting models to an airport using LODS. I keep getting 3 distinct objects in SDK instead of one with all 3 LODS in one XML file. Is there a place to get instructions, like a manual for the new Exporter? I assume the above is easy to fix, but I’m just getting off track.



Keep each Lod meshes in Its own collection, with this naming


  • mesh1
  • mesh2
  • mesh3


  • mesh4
  • mesh5
  • mesh6


  • mesh4
  • mesh5
  • mesh6

And in the multiexporter, click on Group Lod by Collection
(Collection will be grouped according to the collectionName, in the sample above you can see they are all the same name- ObjectName-)

I think that is what I am doing, however when it comes to adding ObjectName into the scenery, I get 3 distinct scenery objects. ObjectName_LOD0, ObjectName_LOD1 etc. So I need to place each object exactly in the same place in the scene… imposible? I think I should see only one object in the scenery file, ex ObjectName and within the xml there should be the breakdowns by LOD as you have above. However, with the new exporter; and I select the Grouped by Selection, (I don’t see a Group by LOD Selection) I have tried every iteration.
In the Objects section I check basically everything. I’ve even unchecked each box below Folder: and gave each collection the same file name. Somewhat confusing?


yeah, It is Groupep By Collections,

:slight_smile: wish I saw this, but I don’t have the object name and related export fille location under the Group by Collections. I just have each cube seperately.

So I have: (each collection has the same beginning Metal cube) Metal cube LOD0, next collection Metal cube LOD1 etc.

show hidden objects (checked)
Group by collections (checked)

Then right under that I have, instead of the Metal cube and file location, the following for each LOD

centered heading - Metal cube LOD0
left side Generate XML
Overwrite GUID
Folder: then folder location box
Metal cube LOD0 LOD value 0
file name Metal cube LOD0

I could show you a screen shot but I haven’t figured out where the download screenshot button is on this site.:slight_smile:

Ok… I found the answer. I need to put an underscore between the Object name in the collection and the LOD number
I had an older version of Export. The newest version available in Tools of SDK works as you have shown. Thanks