Issue with my own custom textures after the SU7

Hello to all. I have issue with my own custom textures after the SU7. I has
created my own custom textures for my project. “Number_1” and “Gate_2048”. So
I created a new “apron” and changed the textures for my one. As you can see I
also set the “Force draw above runways” and “Priority” on number 6. The asfalt
apron under my own texture has “Priority” set on 2. Here you can see my
another own custom texture “Gate_2048”. This textures has size: 2048x2048 px.
The “Number_1” texture has size: 512x512 px. I didnt have any problem to put
them into the project via SDK. When I finish on my project I clicked on “Save
Scenery” and after that on “Build Package”. Everything was great. No mistakes
, problems. So I closed my simulator. Copy and paste the new package of my
project into the community folder. I started the sim. and here is the problem.
No kind of my own custom textures are visible. When I open SDK and loaded my
project, every my own custom textures are there and nice visible. I tried many
things. At first I checked SDK manual if I haven’t forgotten anything.
https://docs.flightsimulator.com/html/index.htm#t=Developer_Mode%2FMaterial_Editor%2FThe_Material_Editor.htm&rhsearch;=materialLib&rhhlterm;=materialLib&ux;=search
After I tried re-load my custom textures. Changed materials from “unknown” to
“asfalt” and so on. As you can see, my library of custom textures are OK
without any errors. I has created couple of projects with my own custom
textures { included this two textures } before SU7 and it workt. So I really
dont know what hapend. If something has been changed in SDK, or what. I dont
know. When I closed SDK and restart the airport location, my custom textures
are visible. But not if I restart the whole simulator. Please, could anybody
to help me with this, or would be possible to check my project? Thanks a lot.
Martin

And one more screenshot. Also I have installed newest SDK 0.16.0 , all
simulator actualizations and active Steam Beta:
sim_update_vii_update.

Not sure what is the problem, but you could try at least one thing. After
saving the scenery, don’t build package anymore after that. Just drop the
package to community folder after saving scenery and closing the sim. Hope you
find a solution. Also load in editor your material lib before saving the
scenery.

Hello. Thank you for reply. I tried it do like you wrote me. But unfortunately
it doesnt work. In addition, I think it is necessary to built package when you
finish.

I had similar problem in past, only when working in scenery editor, in my case
the problem was the materials cache. Try clean your cache files inside of the
project _PackageInt folder and
*%LOCALAPPDATA%\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe* Hope you
find a solution.

Hello. Thanks for info. I have Steam version of Flight Simulator installed on
“D” disk. Unfortunately I can not find nowhere in my PC path :
%LOCALAPPDATA%\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\ I tried to
delete “_PackageInt” folder and also “Roling Cache” direct in MSFS. Nothing
helps :{

Hello @maverick60 Can you send me a link to
your package sources so I can see if the problem occurs on any machine or if
it’s cache related as Leonardo suggested? You can provide a OneDrive, Google
drive or WeTransfer link as private comment using the visibility option below
the “Submit” button. Your materials are named Numer_1 and Gate_2048 but so are
the texture files? Regards, Sylvain

Hello Sylvain. Thank you for help in advance. Here is the link on Google
drive. Martin <https://drive.google.com/file/d/1IrE_gS-
lyN8AAerm3VqdqUWPPuYDnSmb/view?usp=sharing>

Hello Sylvain.

Please, let me know if you are able to download these project from Google
Disk.

Thanks

Martin

Hello. I got it. I’ll come back to you when I know more about what’s
happening. Regards, Sylvain

@maverick60 I have no trouble loading your
package and the correct textures are shown in my case. Can you try to move or
rename the $PC$ directory in *%APPDATA%\Microsoft Flight Simulator* and
restart the game to see if the problem still occurs? Don’t delete it, if it’s
causing the issue, I’ll need to retrieve the content to understand what’s
happening. Let me know if that changes anything. Regards, Sylvain

Hello Sylvain. Thanks for help, but somethings still wrong. At first, I
renamed the original folder " $PC$ " to new name: " MARTIN ". I started
simulator - it doesnt help. At second, I has cut the original " $PC$ " folder from: "C:\Users\Martin\AppData\Roaming\Microsoft Flight Simulator" and paste it into the desktop. I started simulator - it doesnt help At thirdly, I
started MSFS, load the Sandpoint airport, open project in SDK, I loaded the
scenery and after that i click on “Build Package”. Simulator has automaticly
create the new folder " $PC$ " into the MSFS folder, path abow. After that I
renamed the folder to new name: " MARTIN ". I re-started simulator - it
doesn`t help. If you want, you can download this. There are the original and
renamed folder with materials. <https://drive.google.com/file/d/16eD-
ERhEyrZresNlWeaPwolwv8Gw2UZ9/view?usp=sharing>

Ok then it means that cache $PC$ directory is not causing the issue. Your
package is the only one present in your Community folder? If not, it’s worth
testing with only that package in case there’s some sort of conflict.

Hello Sylvain. I reinstalled whole MSFS today. Added to community couple of
folders with scenery, libraries and so on. Started MSFS to check Sandpoint
airport materials. Wihtout succes. But, when I deleted all folders from
community except for KSZT airport. Tada, my custom textures are on the right
places and vissible. So, it looks, that some scenery, or librarie caused
issues. Now I have to find which one. Many thanks for help and really sorry
that I disturbed you whit this issue. Brgds: Martin

Let me know when you find which one so we can understand why. :slight_smile:

Ok, no problem. Relly thanks for help.

Hi Sylvain. I found out that the custom textures of Sandpoint airport were
caused by my project at Trenčín LZTN. It was actually caused by my custom
textures at this airport. I have absolutely no idea why. They were different
textures with different names. I also didn’t see my textures at Bratislava
LZIB Airport, which I also created. It was caused by another project of mine.
Zilina Airport LZZI. But it was not enough to delete my textures from the
Trencin and Zilina projects in the SDK. First, I deleted my project from the
Community folder. Then I had to delete the “Asset Groups” (MaterialLibs) in
the SDK. Then I deleted the folder (MaterialLibs) from the “Package Sources”
folder and saved the project in the SDK and then Build Package. Subsequently,
I copied the newly created package from the “Package” folder to the Community
folder. Only then did my textures at KSZT and LZIB begin to appear. Another
problem was caused by Zilina Airport. And the fact that Trenčín Airport was
approx 150 meters underground. Before the SU7, that was fine. I have no idea
what to do. All Slovak Airport projects are the work of my team. And this
makes our job very difficult. I really hope, that the new update will return
all to old tracks :slight_smile: Brgds: Martin

I see your material library is just named “materials”. Can you try to prefix
your material library name with the airport icao and change the paths
accordingly and see if that conflict still occurs?

Hi Sylvain. I will try it as you wrote and I will let you know. Thank you.
Martin

Hi Sylvain.

It looks, that your idea { rename “materials” folder - to ICAO_materials }
really helps. Thank you very much for help.

Martin