Jetway Issues on SU 5

Since early beta and after release of SU5, I’m having strange behavior of
jetways at my airport. Sometimes jetways don’t even load, sometimes the jetway
links do not connect. I’m using the latest SDK. Same airport file would work
perfectly before the update. I’ve tried recreating the gate and it does’t
work. What could it be? It usually happens when I load into my airport, If I
fly there, it works correctly sometimes. If I load the project into the
project editor, everything connects right away.

Well I confirm that I have a very similar problem. If I select to appear on
the apron or parked at the gate then I can’t see the jetways. If I choose to
appear on the runway and move to the platform, the jetways appear. and this
happens with some betatester, others can see them and others cannot. it’s
strange. in development mode if I can see them and manipulate them, but once
compiled they are not seen as I explained.

Yep, I have a similar problem too on my ENBR freeware. If I spawn at a gate
close to the terminals or the south end of the runway the jetways spawn fine.
If I spawn at the north parking or north runway end the jetways are gone and
it’s even ignoring some building excludes. For this airport I have 100%
repeatability on my pc. Spawning on H55 works, H56 does not. Interestingly, I
have the same type of jetways at my ENBO freeware, and that airport seems to
work fine. to SDK team: I’ll happily supply project files if it helps. edit:
There seems to be an invisible border running straight through the airport
between H56 and H55. I made additional gates with jetways around H56 and they
disappear if I start from H55. Any jetways north of this border disappear when
spawning on the south side, and any jetways south of this border disappear
when spawning on the north side. It’s not a distance issue.

animation is broken for LODs on SU5, in other words, it’s not synchronized
when switching from one LOD to another. I guess that’s because of new LOD\3D
objects optimization algorithm

My custom rigged jetways (that have been fine for months now) are not
appearing on my exported build/package. They are there while in dev mode
during editing but when you build & export they vanish. I re did all of them
one by one again (even from an old backup) and the issue is still there. The
one that shows on export works flawless though. Its literally just killing the
complete models or only displaying 1 or 2 at times. Completely variable.

%100 the symptoms on my end. I can confirm and replicate this. This is a
bummer. The real time gLTF, the apron issues I worked around - but this is the
icing on the cake. This needs a work around asap or a hotfix. I have to get my
airport out and the jetways that have been working for months suddenly are not
appearing in my export. So discouraging.

What about default(ASOBO) jetway model? Same behavior?

For my specific problem, yes same behaviour if I set an asobo jetway on the
gate. However it works fine with the default scenery.

An update to my airport issue: I get the same behaviour if I set an asobo
jetway on the gates, so it’s not my blender jetways causing it. However, the
default scenery does not have the issue.

I have reported my specific issue with a zendesk ticket (114358). I made a
clean testproject with default jetways to verify the issue. Install the
attached airport and go to ENBR (it should contain only 4 parking spots).
Starting from parking 1 will show jetways at 1 and 11 (green circles).
Starting at 2 will show jetways at 2 and 22 (red circles). edit to make it
clear: parking 1 and 11 is south of the “magic line”. Parking 2 and 22 is
north of the “magic line”. You can’t see south jetways if you start at north,
and you can’t see north jetways if you start at south. Attached:

I sent the same thing to zendesk and I got back a copyd and pasted link to
documentation (LOL). I really really hope theres a fix for this asap. This is
insane. Holding an airport from release myself because of this. Really hope a
formal statemen comes out about this so at least we know they know. Not to
mention my animations broke from a simObject, I am sure its something to do
with the same issue.

I can confirm this bug. The airport loads and gives ZERO warnings on the
Console ( it something is wrong in the hierarchy or animation tags are
missing/wrong, the Console will tell you ), but the same jetways that displays
correctly when starting on a certain gate, sometimes disappear when starting
from another gate, or landing on the airport coming from elsewhere.

@devmode_player, I just re added every single parking and gate through SU5’s
dev editor mode. They dont work still. 2 out of the 6 are there. Function
flawlessly like they have for months now. Then I try it again all over and
then 0 are there…I haven’t slept in 3 days now trying to solve this. How did
you get them in? Should I re not just put in a new GUID but literally try to
resave my GLTF over?..dont see how that would make a difference. Not to
mention theres an animated model I have that isnt a jetway and its animations
are not on the export either but there fine without error on dev mode. Care to
lay out legit steps you took…Did you add the jetway through jetway drop
down when parking selected or the simobject selection route? Please see if you
can help me or us…this is catastrophic for me. I need to solve this.

I did a quick test with attached
project and results are following 1. original BGL - green circles have
jetways, but no jetways on red 2. I decompiled and recompiled original
project as is - red circles have jetways, but no jetways on green 3. I
removed original parking spots and added new ones with all settings by default
- all spots have jetways my conclusions, it is necessary to look at and
modify project to comply with new SU5 requirements enbr_test.jpg

@yorgosGK, are you talking about stock(asobo) or custom made jetway model?
Anyway, before we go further, we need to clarify from ASOBO the state of new
optimization system for 3D objects introduced with SU5. I feel the problem is

Yes it is there for sure, must be. And I was speaking about custom made

custom jetways is another case, any 3d object in game must be SDK compliant to
render correctly, I’m pretty sure that game’s graphic engine may cut off any
improperly designed 3D content as part of xbox optimization as it stated in
last Q&A; session with ASOBO head

thats not the issue here. these are fine and check out…Theyve worked in the
passed and for months now. Rigged beautifully and work properly when they
appear. If there is a setting or something in the SDK…it would be amazing
to hear it from there.

Jetways that are disappearing here ARE SDK compliant. The Console doesn’t
report any errors, which means all the hierarchy is correct (if does, when
they aren’t). And yes, they have all LOD levels, and they DO show but,
sometimes, depending where you start, then same jetway that was visible when
starting from a certain gate, won’t appear if starting from another gate so,
clearly, it’s not a matter of the jetway not being SDK compliant.

that’s why I said that we need to hear clarification from ASOBO on 3D objects
rendering. So far I can see that is not only jetway related issue it’s not
supposed to be bug, but improperly implemented feature