Model attachment

Thanks so much for the new feature. I was looking at the documentation and the
examples. Having a hard time to actually accomplish this. I have done as the
example bellow, but I don’t get this to show. I made the node on the GTLF, and
made the separate xml and gtlf file for the attaching model. But to no avail.
Read many times the documentation, don’t know what I am doring wrong, I get a
warning on compile saying node 0 not found or something to that effect. Can
you folks explain a bit more how this is accomplished?

            ..\livery\DA62_LiveryFS_LOD00.gltf
            
            
        
        
            
        
        
    
    
        
            SomeNodeName
            ..\..\..\..\Instruments\SomeInstrument.xml
        
        
            chair1pos
            ..\..\Shared\Misc\FancyChair.xml

the node chair1pos likely doesn’t exists inside DA62_LOD00.gltf

The SDK example is too confusing. Here is a minimal example:

      attachment_point
      ..\model.child\model.xml

This example assumes that you have two model folders model.parent and
model.child with such structure: [D] SimObject root ├─ [D] model.parent │
├─ [F] model.xml ← The file above │ ├─ [F] parent_LOD0.gltf │ ├─ [F]
parent_LOD1.gltf │ ├─ [F] parent_LOD2.gltf │ └─ [F] parent_LOD3.gltf ├─ [D]
model.child │ ├─ [F] model.xml ← The referenced child model │ └─ [F] (glTF
files …) └─ [D] texture ← Both child and parent will use textures from
parent’s texture folder The parent model has four LOD sizes and each separate
model contains node named attachment_point where the child model will be
attached. Keep in mind that sizes below 5 will not show attachments. You can
of course include models from the same folder too, they don’t have to be in
separate folders. Child object can be any standard model and include its own
LODs, which will be calculated separately.

I am still getting a red warning message “model attachment 0” on compile.
Don’t know what I can be doing wrong. In 3ds max I named the node
'attachment_point" here is what I get

I have tried everything, and
its impossible. This is a simobject

Difficult to help you without looking at your xml file too. In your first
post, you showed an xml calling the default DA62 models so, the reason why you
got the error about chair1pos, was there is no chair1pos node in the default
DA 62 gltfs. Now, it seems you are doing something derived from the default
A320 but, if you are still including the original .GLTFs, to attach something
on it, you must use a node that exists there.

Thanks Umberto, actually is my own gtlf, here is a sample of the xml
attachment_point model.xml I put the attached (child) model in the same folder
where I have this parent GTLF I did a node called ‘attachment_point’ in the
gtlf

You mean you created your own version of all the A321_NEO GLTFs, which have
been modified by adding the attachment_point node ? That would be the only way
for it to work.

Hi Umberto, yes on my own GLTF’s. I just tried doing it with the default DA62,
and get the same error. I had thought the issue may be on my node name. I
don’t know.

Ok, maybe I see what’s wrong: in your last XML, you put the tag
alongside the LOD. tag. It must be inside like this:

I assure you the feature works very good, we are using it extensively in GSX
for MSFS…

Thanks so much Umberto, I think that was the mistake, now I am not getting
that error message. Thank you!

Umberto, when you compile your package, you get the models and such generated?
because I am not getting any error messages but I am not getting the gtlf’s
and such generated in the package when I compile. Might be something wrong I
am doing with the way I have it set up then.

Never mind Umberto, got it sorted, had the code broken somewhere. Thanks!

Good afternoon, please tell little bit more about hou you fixed “model
attachment 0” when compile.

Following as I’m still lost in the woods here. Maybe @virtuali Umberto can
help out? For testing purposes I’ve set up a very simple scenario: This is the
base model in 3DS Max. It contains one base object (BER_Tester001) and one
(the box, BER_Tester_Placer001) that should serve as node where I attach
something to: This is the model
that should later be attached:
All of them are set up in the file structure of the GLTF/XML files attached
(ber-tester.zip). Where the BER_Tester001 XML code looks as follows:

      BER_Tester_Placer001
      BER_TesterConnector001.xml

This looks as simple as it can be and follows all guidelines and everything
discussed above (unless I’m missing something). The result however looks like
this in MSFS:

My expectation
would be that the box would disappear and show the ball instead. Alternatively
I also tried a non visible dummy in 3DS Max. In any case the ball doesn’t show
up. When checking the console logs in MSFS I see that the base GLTF file has
been loaded but not the one that’s containing the ball. There were no errors
when creating the package.

Any ideas anyone? Would be really nice to figure out how to attach models to
another. Thank you!