My MaterialLib/Aprons are displaying incorrect images after SU5 update

I have been working on a project for months without any issues. I downloaded
SU5 and went to load in my project and many aprons are displaying the wrong
image (in the sims dev mode and on the Albedo bitmap preview thumbnail). The
comp.pngs are all fine… When I hover over the thumbnail the PATH of the file
is correct - just not the actual visual element of it. Furthermore - since the
actual DATA is correct my export is flawless and as it should be. It just
chokes or glitches when in dev mode. I cant even make a new material as when I
select my PNG it displays the image completely wrong, it shows me a random
file in my materialLib. See below, its showing me a random image and NOT Final
56 v5.png. Its also rendering it like that in dev mode on the Apron but NOT on
the export… Ive tried to reconnect a new materialLib, delete and rebring my
aprons, clean package, cleaned .nzz files, rolled back GPU drivers, re
installed MSFS and NOTHING is working… I can only BUILD then “load in this
asset” then it all SEEMS fine however then I cannot add my own new material
without the issue.

Same problem!!! All my custom markings are gone, all aprons are gone.
MaterialLib shows the wrong preview on the apron/albedo

For the record on RTX 3080 with 471.41. Also tried the 2 previous builds. Same
outcome. I need to not have my MaterialLib connected to my definitions in
order to load in my BGL without issues. Then of course I dont have a lib to
add new ones and work…super frustrating. Anything from admins or
mods/sups/support team?

When your MaterialLib has a C:\ it loads in fine but then you cannot make a
new material since its not in your editor. When you make your link to your
asset group relatively (so no C:\ on the path) it completely kills my apron
textures.

Update: I seemed to have found a work around that at least allows you to
continue to work sorta. You need to load in the project at the menus then
“kill” your existing materialLib b4 you load in your BGL. Then it loads with
no issues. Then you need to add a second materialLib and you can actually add
textures. Make sure you dont build the scene unless you reconnect your old
materialLibs back via the definitions externally. I have been doing this now
and it seems to be working okay. This really needs to get fixed asap. Or at
least an acknowledgment.

@yorgosGK Hello. I haven’t seen similar issues
yet. Can you provide us with a package producing the issue so we can check
what’s happening? (Put it in a private comment) Thank you

I have the same issue as you, and it is also causing some existing materials
to not display at all. As with you, when I build and load MSFS everything is
fine. I would also love for this to be looked at, as it is very difficult to
use the editor.

Exactly the same problem here. My comunity folder is empty, I don’t have any
MOD/ADDON installed, I get ghost textures that are not in my material library,
they are materials that maybe I use in other projects, but they are not
installed in my simulator, where do these textures come from? Please it is
urgent, we need help with this.

I don’t understand your explanation, it would be very helpful to understand
what you did to try and continue with the work.

Re select your MaterialLib asset package in game after project airport.xml is
open - then it will put a C:\ infront of the path - then load in the BLG into
editor. Should load it all fine. Please report back as no other workstation
confirmed this worked for them.

Hello, I may be misunderstanding or doing it wrong. I don’t speak English well
and the translator doesn’t do a good job either, so it’s hard for me to
understand what you are telling me to do. But I think I’ve tried and I can’t
get any result.

Show me ur definitions for the asset group materialLib



@yorgosGK Hello, sorry for the absence, I have not
been well these days, the second vaccine against covid 19 left me a little
weak. Let’s see if these images and video are of any help. I can’t get
anything to work right. It’s a disaster.

@FlyingRaccoon @yorgosGK Here is a short video in which you can see what
happens. * I have nothing installed, no aivones, no airport and no MOD/ADDON,
whenever I work I always try to have the simulator completely clean. * The
ghost material that appears if it is mine, it was a material used in another
project with a different name but it is not in my material library nor in an
installed airport, then I ask myself, why this ghost material appears.
https://drive.google.com/file/d/1UhczCOPifzo50anrJP3lIfLf95tz31jL/view?usp=sharing

Yes, this is definitely the big bug we are all having and Asobo needs to fix.
The work around is add all your materials like this (even though they are
wrong thumbnails, the path is correct). Then you re-select an asset package
manually so the path will change to “C:\…” then you will be able to load
in. To at least work and progress. Re select your AssetDir manually - you will
see it adds a C:\ in front, then you will be able to load the right materials
but just not have your MaterialLib mounted.

Hello. I’ve seen this post and will investigate as soon as I have some time
available. Regards, Sylvain

Thank you Sylvain for following up here and looking into this. Just would like
to add - the export is 100% accurate and this only happens in editor mode. You
can also delete the material and add a net new one - the thumbnail will still
be different and it will also show differently on the apron.

My current partial fix is 1. Clean folders named something like “&PC;&” and
“scenery index” in cache folder. 2. Clean all “packages” and “packagesint” in
project folder 3. Restart the project and Import materials one by one, but
may show ghost again after several inputs. 4.Use apron or painted line to
introduce the target materials in a temporary place. If it pops ghost one,
disregard. 5. build the package and put them into community folder. 6.
Before restart sim, do the step 1 and 2 again. 7.Check the built package in
sim if it’s correct. If it’s correct then duplicate the apron or painted line
to continue the project. Not sure if help, but that’s my current walk around.

Hello. I was not able to repro this on a project created from scratch so that
must be depending on the context. Can you provide me with the package you’re
editing in that video as well as the package the ghost material is coming
from? I’ll try to do the exact same steps. Regards, Sylvain

Hi, I already sent you the package in the other thread about the projected
mesh.