Packagebuilder does not create or update the packages folder after update 07 / upgrade to sdk 0.16.0

The last three weeks I have been working in workflow to create gauges and
mouse areas in the cockpit. After update 7 / upgrade to SDK0.16.0 the workflow
was broken. At first I thought I had made a mistake. But even the simplest
change in the Blender model did not show in MSFS anymore. It took me some time
to find out that the Packages folder no longer was updated (or created for
that matter). I re-installed SDK 0.15.0 but that did not help. I created a new
aircraft project with very very simple aircraft using sdk 0.16.0. No luck. I
tried to use the fspackagetool.exe in command mode. The process starts and is
definitely doing things, but in the end nothing happens. A few minutes ago I
tried the build again and it ends with the following information message: ?
false returned by Command=BuildPackages Comment=Rebuild the packages whose
names correspond to the given filter, and for the given project (default fs-
project.xml) NbParam=2 line=BuildPackages roggeberg22-dc3 * …

And now I am stuck. Is there
anyone out there who can help me to get going again? Roggeberg23

According to your snapshot you are missing the mandatory thumbnail in your
ContentInfo folder. Have a look at SimpleAircraft sample in the SDK where we
use a placeholder for this file (C:\MSFS
SDK\Samples\Aircraft\SimpleAircraft\PackageDefinitions\mycompany-aircraft-
simple\ContentInfo\Thumbnail.jpg) Best regards, Eric / Asobo

Hello Eric, I added the thumbnail and problem solved. So simple. Thank you
very much
for your answer and I go on creating gauges and mouse areas.
Being new to this forum I browsed a little and I came across a remark that the
" legacy events" which I am currently using for the mouse actions, will
disappear in the near future. Is this true? And would that mean I have to
learn something new? Kind regards from a happy customer, Roggeberg23