Polygon point placement offset bug in scenery editor?

I fired up the sim this morning to add a new airstrip on a sandbar and started
to have a strange problem with polygon creation. When I click to place the
first Polygon point it is offset from the cursor by hundreds of metres, adding
a 2nd or 3rd points etc the points appear under the cursor position. If I
close the polygon and start a fresh one the problem repeats. This issue is
also happening with apron creation. I’m fully up to date with the SDK and sim
and I haven’t had the issue before on any scenery build Any thoughts? Link to
screen recording of the problem Kev

Hello @Photosbykev , With polygons, unlike
aprons, we can do terraforming so that we have to place each point on the same
level. Because of this, when you add a polygon point on a non-flat terrain,
you will have this behavior. However, you should not have any offset when you
place the apron point. Can you show me a screen recording of this ? Regards,

Morning Boris, the area I’m working in is flat, probably no more than a few
metres elevation change over hundreds of metres. I understand that working
around hilly terrain there could be a visual offset and I’ve seen that on
numerous occasions editing scenery in Papua New Guinea. I’m hearing from other
developers that they are also seeing the same issue since I posted this
problem. I’ll record a session adding polygons and aprons in a few minutes and
link it. best regards Kev

@Boris1 video is processing on Youtube The offset
is happening to polygons and aprons. The workaround I’ve found is to click on
the position of the 1st point WITHOUT pressing Ctrl. Then press Ctrl and click
for the 1st point The world location is 40.237278 -122.206742 if you wish to
test yourself but it is happening in other locations as well regards Kev

@Photosbykev , What’s your game and windows
resolution ? I tried to reproduce this behavior, but I haven’t succeeded yet

Hi @Boris , I’m running in native 1440p in the os and monitor with default
ultra settings Kev

I too have started to notice the same problem. It’s annoying but can be
overcome by allowing the rogue vertex to be one of the vertexes for the
polygon and once the polygon is completed, then drag the rogue vertex back to
where you want it.

Hi all, I’ve unfortunately stumbled into the same problem, which has caused a
lot of issues since I first though the tool wasn’t working, so I would press
it again and it would subsequently work and the object would appear where the
mouse is. The problem is now I have hundreds of rogue objects that have been
placed randomly from those first clicks. It took hours removing all the stray
objects. To recap some findings I’ve made: - It ONLY happens in windowed
mode. When in full screen mode, I cannot replicate (@boris)
- This issue
is still present in the latest SDK - The first click is where the objects
spawns off the screen, the second click the object appears normally. - It’s
currently causing delays with production, we have to click, then delete, then
click again. Very time-consuming. - It happens with any type of one-click
placement objects: Scenery, taxiway points, polygon points, etc.

Hello @AgentMir , Can you show us the behavior in
a video ? Do you use at least 2 monitors to edit your scenery ? Did you set
any scaling
windows ? Regards, Boris

Hello @Boris1 Here’s a quick video showing the
behaviour. Around the 3-second mark, I click to make a taxiway point. It
spawns the point way off screen, so you can see me slewing across to find
where it generated the point. To answer your questions: - I don’t have dual
monitors, single only. - I’ve tried both, with scaling and no scaling in
windows, same behavior. It only happens when MSFS is in windowed mode. The SDK
tools are outside of the window. I hope this helps, thank you.