Polygons, aprons, painted lines no longer work with suddenly low FPS

Hi, In the comments is a link to my project. My polygons to edit the height of
trees, and aprons for runways, grass, etc no longer works. Additionally, since
then, i am suddenly am pegged at around 15fps when usually its in the 40s.
Been working on this project for a few months and never had this issue. The
texture is applied but it no longer shows any material. Similarly for the
polygons, it is there but no longer controls the height of trees i edited, and
it does nothing if it try editing it. All materials used were from the Asobo
materiallib. Some steps I can retrace that led to this (I want to be careful
with how i say it but i really cant confirm what time this problem actually
started happening today, but it fine until today. Draw shapes is active in the
devmode menu. 1) From this morning did some work with models, everything was
fine 2) Updated to WU11 3) Was working on some models for a couple hours with
my project and sim open 4) Exported model and built package to test and see
how it looks in sim 5) Instead of showing the names of the models in my
modellib, it showed their GUIDs i believe with no object showing up. 6)
Deleted the last model I just made and rebuilt, same issue with GUIDs with all
the other models 7) Deleted all the models and textures from modellib folder,
and its only then I noticed all my aprons and polygons did nothing. (The GUID
problem was fixed after deleting all models and textures and importing a new
one) Any help is appreciated. Thanks

EDIT The strange thing is if i
close the project and project editor, the aprons and painted lines etc with
the exception of trees pop up correctly. Reopen the project, and as soon as i
press load in editor it goes away again.

Hello @dougjudy , I tested your package on SU10 and I was not able to
reproduce this behavior. Are you sure your community folder is empty and you
don’t have any scenery on this location ? You can use “Rebuild All” in the
project editor to make a clean build of your project before loading the BGL
Also you can try to [delete your
rolling cache](https://flightsimulator.zendesk.com/hc/en-
Manual-Cache) As for the fps issue, I was still at 59-60 but since you gave us
a light version of your modellib, that may be the cause, I’m not sure.
Regards, Boris

Thanks for the response. Im really at a lost here. Can you confirm when u
loaded in the project you see all the apron materials correctly. This is mine
what it looks like when loaded in .

I tried all your suggestions,
including reinstalling the sdk but it still didn’t work. After trying again
loading the project many times, then the project loaded it correctly with all
the aprons and usual fps. Closed it and tried loading it again, no aprons with
materials and poor fps. Tried 10 times again aprons not loading it. Try again
after it loaded in. There seems to be no pattern. Ill say it manages to load
in the aprons and polygons with textures once every 20 attempts to load the
project. However whenever closing the project, and the editor, and back in the
main sim, I see all the edited aprons as it should be despite the project
being closed. Similarly, if i export the project and test it out with the
package it in community folder, it works correctly. It just that no polygons
and aprons work in the viewport although i see the lines. It seems to only
affect this project, my others work fine

For the extremely slim chance anyone happens to have a similar issue to this,
the reason it was happening is because of the messed up object import where it
was showing the guid instead of the object name. After deleting (what i
thought) was all the objects this issue occurred. Turns out i had a projected
mesh object hiding that i didnt notice, (it was labeled “unknown” as I deleted
its gltf and textures) that somehow causes the aprons, and lines not to show
and low fps. After deleting it, its back to normal again

I confirm the issue. I’m unable to create aprons or see them. There are issues
with Projected Mesh as well as runways (see video).

Getting the same issue as well, don’t have any “unknowns” in my obj list.

Hello @Verticalsim @MKMatt , Are you using DX11/DX12 ? Do you have this
behavior 100% of the time? Are all your projects are impacted by this ?
Regards, Boris