Possible BUG with deleteAllJetways

I’ve observed what looks like a bug with the DeleteAirport, specifically the
deleteAllJetways flag, but it’s possible other flags in the DeleteAirport
might be affected too. If a replacement airport that has custom Jetways in the
Community folder replaces a standard default airport with no “handcrafted”
version, everything works as expected: the new airport can use the
deleteAllJetways flag, and its custom jetways will show with no issues. If the
airport to be replaced has an “handcrafted” version in the Official folder (
doesn’t matter if it’s encrypted, like KSFO or not, like KJFK or KDFW ) which
ALSO use the deleteAllJetways flag itself so, basically, we already have two
versions of the airport and are adding a 3rd, the deleteAllJetways flag works
only the first time the new airport is added. On every subsequent session
of the sim, the replacement jetways which showed up the first time, can’t be
seen anymore. The Console doesn’t report any problems, and confirms the add-on
package has been loaded successfully in all sessions. The problem can be fixed
by manually removing the CONTENT.XML. As soon the file is removed to be
regenerated, the new jetways shows up, but only for that first session. It’s
possible to go back to the Main menu, choose another airport, go back there
and jetways are still showing. Everything works, provided the simulator is not
closed. On the next session, the new jetways are not loaded, so a new cycle
begins, requiring removing the CONTENT.XML again, which always fix the
problem. It doesn’t seem a scenery priority problem. In all cases, the
CONTENT.XML always had the new airport in the last line. There are no other
add-ons in the Community folder and, when the CONTENT.XML is regenerated, the
new one is byte-by-byte identical to the previous one that didn’t work after
the first time. Removing the SceneryIndexes folder doesn’t seem to make any
difference, and it doesn’t seem to change if only the CONTENT.XML is
recreated, as long the installed packages are the same. The one and only thing
that always solves the problem is removing the CONTENT.XML, which fixes the
issue, but just for one session. It seems the loading order works differently
on a session where a CONTENT.XML is being recreated from scratch, compared to
a session in which it was already present. Another thing that fixes the issue,
is manually editing the 2nd “handcrafted” .BGL, to unset the deleteAllJetways
at the binary level, making the new replacement file the only .BGL that
replaces jetways on that airport, which falls back in the first case, where
everything’s working if only one .BGL use the deleteAllJetways flag, which is
the usual situation of default airports with no enhanced version. I even tried
replacing the entire airport, basically creating a clone of the default
airport, with every element present ( taxiways, parkings, runways, ils,
jetways, frequencies ) and the behaviour is still the same: custom jetways
still don’t show, except for the first session when a new CONTENT.XML is
created, but not in subsequent sessions.

@Darwikey FYI

Hello @virtuali We were able to reproduce the problem that actually occurs
with all delete commands. This will be investigated. Regards, Sylvain

Thanks a lot for looking into it, let me know if you need any further info.

I’m bumping this up to report the following: It seems this problem affects
Projected Meshes as well. But, instead of being fixed by removing the
Content.xml before each start ( which fixes the non-working deleteAllJetways
command ), it seems to be more permanent. In fact, what’s the proper method of
Excluding a Projected Mesh, assuming it’s even possible ? Regardless of the
order in the Content.XML file, if two sceneries for the same area both have
Projected Mesh, both will show up. The scenery which is supposed to exclude
the one below already has both Exclusion Rectangles with excludeAllObjects and
Exclude Polygons as well. No issues of double objects, only the Projected
Meshes are duplicated.

I’m bumping this again: has these two issues been fixed for SU9 ? - The
multiple Delete commands not working after the first scenery that deleted
something UNLESS the CONTENT.XML is deleted. - The inability to exclude a
scenery that use a Projected Mesh

@virtuali No, this is not fixed in SU9 yet. Regarding projected meshes, we’ll
add an option for it in Exclusion Rectangles. Regards, Sylvain

Is that fixed now in SU10? Nobody here to answer that?

Seems fixed now …