Problem with the Vector Placement Tool

Should the Vector Placement toll work fully in SU9/SDK0.18? I have made a 2m
long simple wooden fence and placed it in my scenery using Vector Placement
and three points, with a 90 degree angle at the midpoint. The fence fills up
and shows fine in Dev Mode while the project is open. It builds without
errors. But then in the sim (after restart and not in Dev Mode) the fence is
not there. And further - as long as the fence is in the project I get an
immediate CTD when returning from a flight to the Main Menu - 100% of time,
regardless of using Dev Mode or not…

Hello @WildLynxAir , Is is a custom 3d model ? If yes, do you have the same
behavior when replacing your asset with a fs-base scenery object ? Can you
send us a full dump file please ? [See section 2 and 3
bug-or-crash.html) Regards, Boris

Yes, it is a custom model. Have to try with a fs-base object!

The same behaviour happens also in the SU9 official stable I guess the
VectorPlacement should return back to alpha, the following is using fs-base

with the project open,
even without loading in the scenery editor, feels ok, but compiling:
last lod is also loaded in the
air, on the top of lod0

fence04 has a single lod, lets
load it in the air! tarp and
simple fence have multiple lods

Worst: like @WildLyinxAir (why can’t we tag someone else…?) Loading an
airport where a vectorplacement is used, returning in main menu will CTD,
guarantee a simple project (stripping down modellib) LIGC-
and full

Yeah, I’m sad after finally getting to try this. It’s breaking in interesting
ways. Looks perfectly fine in project editor even without loading in scenery
editor. This is using the shortest version of fence_grilling04 in fs-base.

This is what it looks like in the sim with the scenery installed. The first
picture shows Fence A on the left side of the road and Fence B on the right
side of the road. The second picture shows more of Fence A. Fence A (left) is
showing double with one part correctly following the ground and one part being
completely straight with one end floating and the other end under ground.
Fence B (right) is only showing one part. Completely straight. One end
floating and the other end under ground.

Fence C is short. At first it looked like it was the only one working
correctly, showing up following the ground. But then I got suspicious and
turned on wireframe. It too has a straight part buried below ground.

Can confirm the following bugs with Vectorplacement. LOD bug, displays both
LOD0 and LOD4 - the 4th LOD is displayed at a different height, this is
really amplified when your scenery is at altitude. It sits about 100ft in the
air. Crash to desktop every time you load a vector placement scenery in
devmode and try to return to the main menu from dev mode. This is 100%
reproducible every time. Several times we have had it where the XML was
corrupted with an incomplete vectorplacement tag, we manually edited the scene
XML file to locate and remote the offending element.

Hello there, The lod issue has been fixed for SU10 As for the CTDs, we are
investigating Regards, Boris

Thanks for the reply Boris, Are we saying that for the LOD issue
Vectorplacement tool shouldnt be used until SU10 ?

For other developers with 3rd party models changing 90 degrees when using
vector placement. Make sure you have set the following. - you have to have Y
in blender as forward back axis and you have to have all transformations and
scale set to 0

I can’t suggest you to use a tool that has some issues :wink: So yes, you will
need to wait for SU10 and I’m sorry for this delay, Regards, Boris

Hello again, The CTD has been fixed for SU10 (as well as the LODs issue of the
VectorPlacement tool if you didn’t see my comment above) Regards, Boris

Thanks, We just needed to properly understand the impact and time for repair.
Well take steps now to mitigate the issue which will probably include removing
LOD ranges from the XML and delaying the xbox release on the microsoft
platform and just releasing on other platforms for PC only.

Hi Boris, The problem we all now have in the scenery design world is a lot of
us have been using the new Vector tool for the last 3 or more weeks to great
effect. We are now being told that our scenery isn’t going to work properly
and cause CTDs and the earliest we can expect our scenery not to affect users
or be in a releasable state is SU10 which is end of June ? - Our options at
this point look like we reverse 3 week worth of work (remove all Vector
Replacement objects from the scenery) and spend a considerable amount more
time replacing objects manually. - Or halt all releases till SU10 I
understand these fixes have a schedule and more importantly a test schedule,
but is it all possible to post this as a hotfix ? (Probably a big ask)

Do we even understand how we would want it to work in these situations? Are
we expecting the shape of the fence to morph with the hill, maintaining
vertical supports, with each support at ground level at that point?

Hi @HybridNZ , You said you worked 3 weeks on it so I guess it was during the
beta. I suggest you to avoid making production product when using tools that
are in beta state However, I can’t agree more on the fact that this is
exhausting to do all the hard work again, and I understand, Sorry for the
inconvenience caused Regards, Boris

Just adding - CTD for me when exiting flight in any of my sceneries in which
I’ve employed Vector Placement scenery objects. Back to doing miles of maual
fencing! It’s a great tool so I hope we can get it working.

Hello As I said in a previous anwser the CTD issue has been fixed for SU10
Sorry for the delay Regards, Boris

That’s great to know - thanks Boris.

CTD when returning to main menu has been fixed by today’s patch. Thank you.
(Minor issue: the scenery editor will crash if the projects contain
vectorplacement made before the patch. Works fine when they’re deleted and
made again). But models are still doubled up (and the twin doesn’t follow
ground) when the scenery is installed to community.

New bug We now have a pretty bad issue where everything is now
hovering in one of our major sceneries. We have cleaned out all temp files and
old packages and rebuilt from scratch. This is in latest patch These
objects were in the previous SU9 build with vector placement When you load
into dev mode the hovering stops and looks as it should, when you build the
package / exit the sim, comply it to your community folder, load the sim back
up again and spawn into the airport this is what we now see. EDIT Again: Can
confirm this above image happens regardless of whether we have orbx mesh or
not loaded. The height issues happen randomly, sometimes some things float,
sometimes nothing floats and some times anything that is going to float is
floating. Restarting the Sim helps but its more often than not broken. Loading
the scene in dev mode doesn’t display any issues, only when loading into the
game normally does it display the issues. However, the below screenshot is
without ORBX NZ Mesh our custom vector placement models now attach to the
ground however base Sim model don’t. See below. I have tried to move them and
rebuild in case it was a need for the objects to be re-attached to the ground
and rebuilt but this doesn’t fix it. - Also as stated above I can also
confirm the LOD issue is still there for height (you can see it in the fences
on the bottom right of the image above if you zoom in its loading both the
LOD0 and LOD4 at a slight height difference on our custom fence model.
However, that isn’t suffering from the elevation offset issue. Also in the
image below. - Can confirm ‘crash to desktop’ when returning from a vector
placement scenery is now fixed.