Received an intivite to participate in the Closed Alpha but says account not eligable

I received an invite in my email clicked the link for the site and when trying to login it says that my account is not eligable. Is it not up and running yet ?? What is going on ??

Same issue here

I was able to get in just fine, is it the same Xbox email that you used on the form?

Yes, I’m already talking to one of the dev support team members no idea what is going on

did they contact you, or is there any other way to get in contact with them?

They contacted me, but there seem to be a problem when using chrome as browser. I had to use edge in order to login

Using firefox, but will try with Edge

Same issue with Edge on my end…

you can contact https://devsupport.flightsimulator.com/u/BroHammersley he fixed it for me. Now works with chrome too

@BroHammersley what do you need to check the issue with my account?

Hey all, the issue was not browser related but something on our side :slight_smile: . This should now be fixed, but if you’re still having trouble, please @ me here or send me a direct message.

As a reminder, please be sure you are signing-in with the Xbox account provided in the sign-up form (this may or may not be the account that received the e-mail).

Thank you!

2 Likes

Yeah still not able to log-in. @BroHammersley

It looks like there’s another underlying issue at play and we’ll need to spend some time investigating. If you’re having trouble signing-in to the World Hub website, please hold tight and we’ll update this thread once we believe the issue is resolved.

If you haven’t already tried signing-in, the issue does not appear to affect all users (but is affecting a fair number).

Sorry for the sign-in issues and thank you for you patience!

3 Likes

For anyone still having trouble signing in, we made some changes in the last few hours that we believe should help. If you were having trouble signing in yesterday, please try again now.

If you’re still having trouble, please post here or send me a message. Thank you for your patience!

1 Like

I am still unable to log in, but the error message has changed slightly.
image

Thanks to community help, we found edge cases on XBL accounts that were not processed properly. Most of the technical issues regarding this should be fixed by now, if the account and whitelist mails match.