Scenery Objects Empty

After a long break with making sceneries, I updated my sim and SDK and noticed
that the scenery objects(the default/built in ones) are not showing in the
Objects list. I checked the SimObjects type and the objects that belong there
are still there(Asobo planes, airport vehicles, etc).

Another issue is when I click Build Packages, the sim freezes and there’s
nothing I can do but to force close the
sim.

Hello. Can you switch to a different object type, switch back to scenery
objects and confirm the list is now correctly filled? It looks like an UI
initialization issue. Edit: just noticed waiting for a few seconds also works.
There’s just nothing telling you the list is being generated and depending on
how many packages you have and how busy your machine is, it can take quite
some time. Regards, Sylvain

Thanks for the response. I did try changing it to SimObject which loaded the
list really fast. And I did also try waiting on the Scenery Object list(more
than an hour since I had lunch while I waited for it to load), still the list
is empty. My sim and SDK is in an NVME storage so I’m pretty sure speed is not
the issue here.

Jumping in with my experience, with a very small community folder, premium
Deluxe version with all Wu installed takes about 30 seconds to load Maybe you
can try to empty your community folder in order to exclude any package slowing
down assets loading? By the way, on my side, loading of Simobjets or loading a
project with some Simobjects asset group lead to a momentary freeze of the sdk
interface (20 seconds or so)

The time I tested it, my sim and SDK just got updated. I always clear out my
community folder whenever there’s a new update. So there were no files inside
the community folder when that happened. I was also trying to create a new
project that time so I didnt load any project that time.

Can some dev assist me on this? I tried to delete my Microsoft Flight
Simulator folder in appdata just to see if it helps but no luck.

Have you checked the virtual file system window ?

@Nardz And switching back to Scenery Objects after the SimObject list has been
correctly created doesn’t help? @Darwikey Any other suggestions?

Hi, "Another issue is when I click Build Packages, the sim freezes and there’s
nothing I can do but to force close the sim. " For me the issue is here, the
build package failed. Have you tried to look at your generated .bgl files ?
And check the timestamps. Xavier

@Nardz Also, do you have the same issue if you open another scenery? (the SDK
SimpleScenery for instance) If this is related to your package, you can send
the sources to us and we’ll investigate. Regards, Asobo / Sylvain

I reinstalled the whole sim(I havent reinstalled it since release and I got
the press_release copy of the sim, if that is a factor) and it got fixed. I
dont know what might have caused it.

I have the same problem and I don’t want to reinstall the simulator what do I
do?

And it creates a window saying that it fails to read files. If I click ok the
simulator crashes at the same time

Hello @RaulAires , When you say you have the same problem, does that mean you
also have an empty list in the collumn “Packages” of the objects window? Did
you try with other projects and by waiting few seconds to a minute ? Regards,
Boris

It seems like its a while ago since the last post in this topic. Any updates or solutions?

I experience the same problem, which is no objects showing in the scenery-objects list.
Like Nardz I checked the SimObjects and that list works fine.

I use SDK update 0.22.3 and I’m new to SDK, so have not used it before.

Did you empty your community before trying?
I recently helped a friend with same issue, and once cleaned the community he was able to go ahead with development
Also, if you are an avid Marketplace user, a large Official folder takes its time to load

Thanks a lot!

Seems to work indeed. I guess there were too much files in my Community-folder, so it took SDK ages to load the objects.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.