Scenery polygon and apron not showing any material and not excluding anything

Hello! Yestrerday I continued to work on my Airport Scenery and noticed that
neither of my polygons (scenery) nor apron objects showing any material
(doesn’t matter if custom materials or the standard Asobo materials). They
also don’t have any effct on vegetation. So for example grass is now going
through the 3d objects. The only thing works is terraforming. Does anybody
know ANY information regarding this issue that could help me to solve the
problem? Thanks alot!

Hello @mailman , I’m not sure to understand your issues,

For your screenshot with the polygon , when you check ‘Vegetation’ the fact
that the material is not showing is expected. And for the second screenshot,
the apron, you need to check ‘Draw surface’ and it should works as expected

Hello @Boris ! Thanks you very much for your answer. I checked your
suggestion and and “draw surface” was on, I think I accidently uploaded a
screenshot, where it was unchecked. But it actually doesn’t even change
anything when I switch on or off. It is a bit complex but I was able to
reproduce the situation and I think the way to show it to you, is a video. So
I recorded one. I very sorry, that it got a bit long but I tried to explain
what’s going on showed what exactly I was doing and how to reproduce this
strange behaviour. I hope there is a solution for that, because it makes work
within the Dev-Mode impossible. Here is the video: Thank you again! I hope you can

Hello @mailman , Thank you for this well edited video ! Indeed, something
strange is happening… Can you send us your project please ? (see the section
about ‘[Provide private
bug-or-crash.html)’ ) Regards, Boris

Hello again! Indeed, it is quite strange. I also opened a new project for
testing, to find out exactly that, but unfortunately it was still the same
problem. But I’ll send it you anyways, maybe you will find anything I can’t
see. Thnaks!

I wonder if this is the same issue shown here: [Vegetation slider doesn’t work
anymore - MSFS DevSupport
slider-doesnt-work-anymore.html?childToView=5391#answer-5391) …as you stated
that it worked properly with dev mode turned off. I’ve given the steps I took
to fix it, and this worked for the OP as well, so might be worth giving it a

Hi! Thanks for your answer. But unfortunately it’s something different. Devs
try to figure it out, maybe they are more lucky. Best regards!

Hello @mailman , We haven’t been able to reproduce your problem and, at this
time, we are not sure what is causing it. The next update (SU8) is coming next
Monday. Can you please test again when you have it installed and tell us if
you still have the problem ? Thanks, Regards, Boris

Hello @Boris ! Unfortunately the Update 7 didn’t change anything and I still
have the error, that polygons don’t function correctly after activating Dev-
Mode. I also uninstalled MSFS and installed it again on a new drive.
Unfortunately no change. I really need help urgent, because I can’t work on
any project! Does this thread maybe has some parallels?
correctly-msfs-2020-sdk-0-7.450077/> I hope you can help me somehow. Best
regards, mailman

Hello @mailman , I think you are talking about SU8 :wink: - Is your community
folder empty ? If not, delete all packages in the community folder - Do you
edit some xml file by hand ? - Close Flight Simulator In the folowing folder


There is a file named Devmode.xml Rename it to Devmode.xml.old for example
and start the game Open the dev mode, your scenery, and tell me if you have
the same issue or not If you have no longer the issue, please send us you
Devmode.xml.old file Regards, Boris

Thank you very much for the quick respond @Boris ! Sorry, SURE I mean SU8,
not 7! 1. Yes Community folder is empty. 2. No, just opened them to have a
look at the structure and never saved them, alsways closed them without
saving. But an interesting thing is. I opened the folder you have described
and could not see any “Devmode.xml” in there! But there is a “packages” folder
with some user information files of a “justflight-aircraft-pa28-arrow-iii”
which I bought once. BUT this one is NOT installed at the moment, because I
did a fresh install of MSFS, as I already said. Is this maybe the problem?
What actually is in this Devmode.xml ? Or is it maybe located somewhere else
for the Steam-Versions of the game?

For the steam version, the file is located here:

\Users\[USERNAME]\AppData\Roaming\Microsoft Flight Simulator\DevMode.xml

Finally I got it running. The solution for me was, deleting everything in

\Users\[USERNAME]\AppData\Roaming\Microsoft Flight Simulator\

and the whole "Microsoft.FlightSimulator_8wekyb3d8bbwe " folder in


Still no idea how and what went wrong there. But at least it looks like it is
working now. Thank you very much @Boris !

Glad your devmode environment is working again :wink: Regards, Boris

I had the same problem and found that it was caused by the settings. The
effect also exists when leaving development mode.