Series S customers report missing major objects

Hi! Starting around June (2023), Xbox Series S (not X!) customers report
missing major scenery elements, such as terminal walls or even entire
terminals. We do not own a Series S (only X) for tests, but such issues were
never reported before June. Please advise what can be done about that or how
to troubleshoot the issue. Our Xbox products already have 50-75% lower texture
resolution, 50% lower ground resolution, and many detail objects removed for
optimization, such as people, animations, static aircraft, interior details,
and static cars. Apparently, there is not much left :smiley:

Having similar issues. Would be good if someone could assist us both.

In our case, this is solely a Series S problem too.

Hello @DrzewieckiDesign
@MKMatt It is likely caused by the console running
out of memory. We have a process that will start unloading objects to avoid a
crash in such case. We would need the list of packages your users have
installed to try to reproduce the issue ourselves and see what’s the best
course of action. Regards, Sylvain

In my case I used fresh MSFS installation on Xbox series S. Nothing else
installed but Dublin (through Marketplace).

Ok, we will try to reproduce this here then and I’ll come back to you when I
have more information. What aircraft were you flying when you had the issue?

@FlyingRaccoon Tried a few default planes, mostly Cessna and A320. There was
no difference.

I guess if Dublin generates issues then our KEWR Newark will too, as it almost
certainly is heavier. But we need to keep in mind that those products work
correctly on the Xs and (at least in our case) the reports about Series S
started to appear only about a month ago. Customers did tests on default
aircraft with AI off.

The user confirms testing products with no other content in the Community
folder and with a default aircraft.

@FlyingRaccoon any luck on reproducing this
one? Are there any specific vertex/drawcall limits for series S consoles?

Do the objects have multiple LODs ? If the LOD strategy in the SDK docs is
enforced on Xbox, to be sure your objects are not removed outside your
control, they must have at least 3 LODs, at least this is what the docs are

Hello @MKMatt We have been able to reproduce the
problem. That is also a problem we have with some of our own airports so this
is already tracked. I can’t tell yet if that’s an issue on our side or if the
sceneries in question need to be simplified further. Regards, Sylvain

Hi Sylvain. @FlyingRaccoon So I guess we do
not know much more than we did before, correct? There is one issue with
simplifying products - customers have to get the same price, screenshots, and
descriptions as in “full”, PC-dedicated products. Even though the Xbox version
is significantly simplified. Some of the users are a bit frustrated about that
and I can understand why. Additionally, you can see that in ratings - our
products mostly have 5 or 1 stars. Frankly, 5s are from PC users and 1s are
from some of the Xbox users. There is rarely anything in between. If products
just crash, 1s are perfectly logical. Unfortunately, we do not have any stats
of Xbox vs PC product sales but I wonder if it is viable to sacrifice product
ratings for Xbox sales…

They do indeed.

Hello @DrzewieckiDesign We haven’t moved
forward on this yet unfortunately. I am still following and will let you know
when we do. As for the way the product is presented on the Marketplace, this
is more of an editorial subject than a technical issue so you want to discuss
this with your partnership program contact. Regards, Sylvain

1 Like

Hello Sylvain @FlyingRaccoon . Do we have any progress regarding this matter?

The Marketplace presentation is indeed not your issue, but on the other hand, such limitation on Xbox products results in a completely different product being sold for Xbox than the one presented in screenshots…

Anyway, the disappearing objects is the main concern here. :sob:

Guys, I am really sorry, but I just need to bump up this topic. :sleepy:

Hello @DrzewieckiDesign,

This issue will not be solved with SU13, it is still being investigated.
I’ll update this topic when we make some progress.


1 Like

FYI this is happening in Montreal as well. Last Marketplace 1.1.0 release.

There’s only one building missing all the time. Even though we significantly optimized the scenery it still won’t show up.

1 Like