Simple shape collisions exporting issue

Hi, while exporting a scenery object with complex(4+ colliders) structure of
the simple shape colliders, some of the colliders do not work and appear as
white boxes in collisions debug. Colliders have unique IDs and linked to the
LOD0, but it’s impossible to predict which collider will not be exported
correctly next time, it’s pure random process. The only way to workaround is
to export as many times as required to get all colliders to work. I see the
problem in 3ds max exporter, because the FS core engine handles the collisions
in proper way I use Multi File Exporting best

Hello Can you provide us with gltf + xml file for that scenery object so we
can check what’s going wrong? Regards, Sylvain

Hi Sylvain, will do, what’s the best way to send it in private? also textures
needed? regards

You can post a private comment by selecting the visibility below the submit
button. (Select moderators and original poster)
No textures needed.

Hello @devmode_player I checked your GLTF and the shapes appearing in white
are missing the collision tag. Can you make sure the collision checkbox is
checked on those shapes? If so, that means we have a bug with the exporter.
What SDK version are you using? Can you provide us with the .max file so we
can try to repro? Regards, Sylvain

Hi Sylvain, Collision tags are in place for all colliders in the scene, it
seems that problem in exporter or in game collision engine. anyway, I’m gonna
make a 3ds max file for you ASAP thanks

Hello @devmode_player That’s definitely an exporter bug. It looks like an
initialization issue. Can you uncheck/check one of the white shape “Is
Collider” option, export and confirm all gizmos now have the collision tag in
the GLTF? We’ll look for a fix in the exporter. (@lpierabella FYI) Regards,
Sylvain

Hi, I did it and can confirm no changes for the white shape, it still appears
in white, but also there are 3 more shapes have lost collision tags in game.
update, I tried to play with “Is Collider” option for other gizmos and have to
say it does not work. Shapes receive a random collision tag regardless “Is
Collider” option status best

Ok then the best course of action for you is to manually add those tags in the
gltf file and we will fix the issue with the exporter on our side. Sorry for
the inconvenience. Regards, Sylvain

Sylvain, I can confirm that is 100% exporter bug, while the model has 23
collision shapes, not all of them being exported to gltf file on random base.
I found no presence of 1 to 4 shapes in gltf file Unfortunately there is no
easy workaround other than to fix the exporter. best regards