Simvarwatcher not updated 0.17 SDK per release notes (solved SU9 beta 1.25.5)

Simvarwatcher program simvar.exe and VS files have not been up[dated per the
release notes.

Simvar watcher

Updated the simvar watcher to add the following features :

  • Add a search bar for Simvar names
  • Select default unit when a simvar is selected
  • Support string value request
  • Display only compatible units
  • Add Top Menu
  • Add a copy Value / Name / Unit when right click on a simvar request
  • Add Icon
  • Add Remove all option in contextual menu

Hello @DA40CGDFQ , Thanks for reporting this, We are investigating what
happened. Regards, Boris

I guess same issue with SimConnect files. There should have been a new Flag
for waypoints, but files are still one the old date from 2020 and 2021.

I see the SDK has been updated with the new simvarwatcher program (SU9 beta
1.25.5), but you guys should really learn versioning. SDK should be 0.18.0.1
for this minor update. :wink:

Thanks for the advice but this is the SDK for the SU9 flighting, which is why
we bumped the minor version. :wink: Best regards, Eric / Asobo

Okay, folks, it might be totally obvious, but at least I missed the separation
between the MSFS SDK and the example code. Which happens to include the
(updated) Simvar Watcher example! Here is the pitfall I fell into. I hope this
helps anyone else in the future, too: * At least at some earlier point the
MSFS SDK included all required SDK tools and the example code, including the
Simvar Watcher () * Ever since then I downloaded the latest MSFS SDK via the
flight simulator, including the latest 0.18.0 version, and I always assumed
that the installer would properly update all previous files (now you see where
this is getting at ;)) * Since I only ever use the SimConnect API (so I really
just copy over the DLL into my project and use the corresponding include
headers, that’s all really) and the Simvar Watcher I never experienced
anything suspicious, until of course… * … an announcement was made for SU
8 that the Simvar Watcher example app would be updated as well, getting a new
simulation variables search field and what not! * Now this didn’t happen, so
another MSFS SDK 0.18.0 release was made, which was supposed to finally
include the announced Simvar Watcher - except that I still had the old version
So what happened? To make sure I re-downloaded the latest MSFS SDK 0.18.0,
installed it again - but same result: same old Simvar Watcher. Recently
someone posted a screenshot of the updated Simvar Watcher - so there must be a
way to get it then! So I re-downloaded the SDK for the third time (again the
0.18.0), but this time I made sure to choose “Remove” first. I quickly wanted
to check the default installation folder on C:\MSFS SDK\ folder and… what’s
that? The SDK tools are gone as expected - but all examples remained in place?
Is the installer broken then? Doesn’t it properly register all its files? And
then it dawned on me: “Did they perhaps split the examples into another
download”? And of course, that was the solution!

There is “now” (well, perhaps
since months ;)) a separate “Samples” download, and it includes the updated
Simvar Watcher example! Problem solved :slight_smile: I hope I could help someone else
possibly stumbling into the same pitfall here. (
) UPDATE: Perhaps even not
and I just imagined that the SDK Installer once included everything (including
samples) at some earlier point: perhaps I simply forgot that I once had
downloaded and installed the Samples already, but I simply forgot about it
being a separate download (as it ends up in the same C:\MSFS SDK\ folder).