[Solved]Error - Using Fuel System SimVar without having a Fuel System

Building my aircraft I am now getting an error that keeps repeating in the
consolde and ends up being 10 of thousands of errors. The aircraft does not
have a [Fuel System] section it uses legacy fuel, the checkbox is checked in
the AE2. A second aircraft works fine. What would cause this error to repeat.
The aircraft xml code is not working correctly and will not bring in other
library xml files. The folder structure is similar between the two aircraft.
Just the folder names are different. The build compiles fine, there is no fail
message. Behaviors load, except for the lib xml files. Using tag not error
is Attempting to call FuelSystem simvar on a plane which doesn’t use the
modular FuelSystem. Sim running 10 seconds - filter on
attempt

aircraft loaded - sim
running 15 seconds

Following seeing this too…

I have progressed a bit further with this issue. I have two aircraft (the
(I’ll call errorplane) one with the error and a second testplane without the
error) and decided to copy the model xml code from the errorplane to the
testplane. Both interior and exterior. When I build the testplane aircraft
with this modification I got the error about the fuel system simvar. Ok now I
can reproduce it. I then removed the interior xml from the tesplane and
replaced it with it’s original interior xml, I rebuilt the testplane (from the
main menu - if you don’t the error code remains in memory and continues). The
error disappeared. I then copied back the errorplane interior xml to the
testplane, and replaced the exterior xml with the original testplane exterior
xml. The error came back. So something in the errorplane interior xml code. I
then commented out all fuel related xml code in the interior xml. The error
disappeared. I reintroduced each component that had related to fuel and found
that this code can lead to the Fuel System simvar error.

I can reliably cause the error to appear and disappear in the testplane.
HOWEVER, I commneted out this code in the errorplane and I still get the
fuelsystem simvar error in the errorplane. I have since changed the mixture
code to

          1
          FUEL_Mixture

I have yet to figure out why it still causes an error in the errorplane
version. There is this strange memory/caching issue with rebuilding an
aircraft and the error remains. The only way to stop this caching, is to exit
the sim and restart it in most cases. I also did a clean all (project editor -
not inspector) before each and every rebuild and did the rebuild at the main
menu

An update now to this. The sound.xml file can also reference simvars, my
fuelpump sound was being triggered by

Since this is triggering FUELSYSTEM simvar it causes the repeated error.
Commenting out this code fixed the issue. Please ASOBO make the error
reporting in the console more detailed in where the error is happening. So any
other devs out there. Check ALL your xml code for your aircraft. Search for
FUELSYSTEM this should indicate to you if you are doing something similar.
Copy pasting ASOBO code needs to be validated. I would assume that if there
are aircraft out there that have this and the dev did not check the sim will
run out out of memory or CTD?? with over 5000 errors in 1 minute.

Hello @DA40CGDFQ This is checked at runtime and we have no way to track which
module or API was used to request this simvar at the moment. The best way to
do this would be a XML validator on package build but that’s not something we
have yet. In the meantime, I’ve asked that we add the plane name and simvar
name so that’s at least easier to track by searching any reference to that
simvar in your whole package. Regards, Sylvain